Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455760 - pkg updates do not notify rhn/sat of removal of old versions
Summary: pkg updates do not notify rhn/sat of removal of old versions
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin
Version: 5.2
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Pradeep Kilambi
QA Contact: Jan Hutař
URL:
Whiteboard:
: 445508 (view as bug list)
Depends On: 455759
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-17 16:36 UTC by Martin Poole
Modified: 2009-01-20 21:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-20 21:54:55 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0195 normal SHIPPED_LIVE yum-rhn-plugin bug fix and enhancement update 2009-01-20 16:06:01 UTC

Description Martin Poole 2008-07-17 16:36:49 UTC
Description of problem:

package changes via yum-rhn-plugin are notified back to rhn/sat with a
delta_packages call listing added/removed packages.  If a package is updated the
new package and revision is added to the package profile on rhn/sat but the old
version is not removed from the profile.

Version-Release number of selected component (if applicable):

yum-rhn-plugin-0.5.3-6.el5_2.6

How reproducible:

Always.

Steps to Reproduce:
1. Install system not fully updated.
2. rhn-profile-sync
3. yum update
  
Actual results:

updated packages will appear twice on rhn/sat

Expected results:

current packages only should be listed on rhn/sat

Additional info:

This is something about adding the outgoing packages to the "removed" list in
make_package_delta in /usr/lib/yum-plugins/rhnplugin.py

**IMPORTANT **
No package removals will be visible until rhn/sat has been updated to fix BZ#455759

Comment 1 RHEL Product and Program Management 2008-07-17 19:41:59 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 2 Jan Hutař 2008-07-22 07:01:57 UTC
I think that remove action is not handled as well - see Bug 445508

Comment 4 Pradeep Kilambi 2008-08-22 19:43:49 UTC
*** Bug 445508 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2009-01-20 21:54:55 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0195.html


Note You need to log in before you can comment on or make changes to this bug.