Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455734 - broken dep in rawhide
Summary: broken dep in rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: w3m
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Parag Nemade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-17 14:11 UTC by drago01
Modified: 2008-07-18 03:20 UTC (History)
1 user (show)

Fixed In Version: 0.5.2-11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-18 03:20:55 UTC


Attachments (Terms of Use)

Description drago01 2008-07-17 14:11:19 UTC
gpm got updated in rawhide with a soname bump, which breaks w3m because it is
built against the old version.
This breaks ABI but the API is the same so a rebuild will fix it.
The problem is that a simple rebuild won't work because something in the build
deps (docbook-utils) requires text-www-browser which pulls in w3m and fails due
to the broken dep.
A solution is to buildrequire another text-www-browser provider and build w3m.
After this build is done the buildrequire can be removed again.
I have done a scratch build
http://koji.fedoraproject.org/koji/taskinfo?taskID=722426 which works. I wanted
to fix the regular package too but the ACLs are closed (no cvsextras allowed).
Please fix this and consider opening the ACLs to allow other maintainers to
apply small fixes like this one.

Comment 1 Mamoru TASAKA 2008-07-17 15:16:33 UTC
Asked rel-eng team:
https://fedorahosted.org/rel-eng/ticket/740

Comment 2 Mamoru TASAKA 2008-07-18 03:12:10 UTC
Now Parag opened ACL to cvsextras, I will fix this.

Comment 3 Mamoru TASAKA 2008-07-18 03:20:55 UTC
Fixed.

* Fri Jul 18 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 0.5.2-11
- Add BR: lynx which provides "text-www-browser" virtual Provides
  to avoid BR dependency loop between gtk2-devel and w3m (shorter name wins
  the game with yum)
  Proposed by drago01 <drago01@gmail.com> rh#455734



Note You need to log in before you can comment on or make changes to this bug.