Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455730 - Found core dump
Summary: Found core dump
Keywords:
Status: CLOSED DUPLICATE of bug 454081
Alias: None
Product: Fedora
Classification: Fedora
Component: yelp
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-17 13:20 UTC by Zdenek Kabelac
Modified: 2018-04-11 17:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-22 10:30:45 UTC


Attachments (Terms of Use)

Description Zdenek Kabelac 2008-07-17 13:20:36 UTC
Description of problem:

I've noticed a core dump left by the gnome-help application.

I'm not using it often and I'm not even sure what I've been doing at the moment
of that crash.

So here is at least the backtrace that might help.

#0  0x00000033e001012a in nsEmbedStream::AppendToStream (this=<value optimized
out>, aData=<value optimized out>, 
    aLen=<value optimized out>) at nsEmbedStream.cpp:199
#1  0x00000033dfa1a271 in EmbedPrivate::AppendToStream (this=<value optimized
out>, aData=<value optimized out>, 
    aLen=<value optimized out>) at EmbedPrivate.cpp:689
#2  0x00000000004146de in window_write_html (data=0x226d010) at yelp-window.c:2743
#3  0x000000000041616d in page_request_cb (document=<value optimized out>,
signal=<value optimized out>, 
    req_id=<value optimized out>, func_data=0x1dad700, window=0x1d000b0) at
yelp-window.c:888
#4  0x000000000041d5bb in request_idle_page (request=0x1d41040) at
yelp-document.c:674
#5  0x00000033d46376c2 in g_main_dispatch () at gmain.c:2068
#6  IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2620
#7  0x00000033d463ae5d in g_main_context_iterate (context=<value optimized out>,
block=<value optimized out>, 
    dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2701
#8  0x00000033d463b38d in IA__g_main_loop_run (loop=<value optimized out>) at
gmain.c:2924
#9  0x00000033d93670c5 in IA__gtk_main () at gtkmain.c:1172
#10 0x00000000004198f4 in main_start () at yelp-main.c:121
#11 main (argc=<value optimized out>, argv=<value optimized out>) at yelp-main.c:415

up
up (in yelp-window.c:2743)

(gdb) print html
$1 = (YelpHtml *) 0x1d8bc20
(gdb) print contents
$2 = "<html xmlns=\"http://www.w3.org/1999/xhtml\"><head><title>Adding an Object
to a Panel</title><link rel=\"previous\" href=\"#gospanel-100\"
title=\"Interacting With Panel Objects\"/><link rel=\"next\" href=\"#gos"...
(gdb) print read
$3 = <value optimized out>
(gdb) print *html
$4 = {parent = {bin = {container = {widget = {object = {parent_instance =
{g_type_instance = {g_class = 0x1db2c00}, ref_count = 2, 
              qdata = 0x1ddb040}, flags = 2164672}, private_flags = 3584, state
= 0 '\0', saved_state = 0 '\0', 
          name = 0x1db36d0 "gtkmozembed", style = 0x1cee000, requisition =
{width = 0, height = 0}, allocation = {x = 0, y = 86, 
            width = 600, height = 588}, window = 0x1ee6f00, parent = 0x1d721c0},
focus_child = 0x1ee9010, border_width = 0, 
        need_resize = 0, resize_mode = 0, reallocate_redraws = 0,
has_focus_chain = 0}, child = 0x1ee9010}, data = 0x1db35e0}, 
  priv = 0x1d8bcb0}

Might be the bug in xulrunner...
Feel free to move to the right place

Version-Release number of selected component (if applicable):
yelp-2.22.1-2.fc10.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Matěj Cepl 2008-07-22 10:30:45 UTC

*** This bug has been marked as a duplicate of 454081 ***


Note You need to log in before you can comment on or make changes to this bug.