Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455715 - updated kernel blocks login
Summary: updated kernel blocks login
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 9
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-17 11:23 UTC by Ronny Fischer
Modified: 2008-08-05 04:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-05 04:58:25 UTC


Attachments (Terms of Use)

Description Ronny Fischer 2008-07-17 11:23:16 UTC
Description of problem:

after updating Fedora 9 to kernel 2.6.25.10-86 the bootprocess comes with a 
kerneloops warning and login isn't possible. I entered username and password, 
but no login happened (meanwhile I was taking a shower!)

Version-Release number of selected component (if applicable):

fedora 9 64 Bit, Kernel 2.6.25.10-86
 
How reproducible:

always

Steps to Reproduce:
1. upgraded to the latest kernel
2.
3.
  
Actual results:

login screen appears with delay, no login possible

Expected results:

the opposite of the actual results

Additional info:

system hardware is an actual Core2Duo with Intel P35 chipset, the automatic 
kerneloops report has been send

Comment 1 Ronny Fischer 2008-07-27 07:17:06 UTC
Update:

Same thing happens with the new 2.6.25.11 kernel. Also this kerneloops has been 
send. Additional to that is that the keyboard does not work any more with this 
new kernel, with 2.6.25.10 I could enter my password, now there isn't any 
activity with that.

I also would like to know if anyone deals with this task, there's no response 
by now.

Furthermore I like to mention that the kernel 2.6.25.9 works fine. I'm 
wondering why a kernel update should make the login unimpossible.

Thanx in advance

Comment 2 Ronny Fischer 2008-07-27 11:18:25 UTC
Another update:

I tracked the error down to the wpa_supplicant application. At my system it is 
used with an Atheros card and the madwifi driver.

Following output is generated when wpa_supplicant is started:

service wpa_supplicant start
wpa_supplicant wird gestartet: /etc/wpa_supplicant/wpa_supplicant.conf, -iath0, 
-Dwext                                                     [  OK  ]
[root@Cyrodiil kaonashi]# 
Message from syslogd@Cyrodiil at Jul 27 13:06:23 ...
 kernel: Oops: 0000 [1] SMP 

Message from syslogd@Cyrodiil at Jul 27 13:06:23 ...
 kernel: Code: c7 45 b8 01 00 41 83 bb d8 02 00 00 06 75 0a 8b 06 89 45 ba 8b 
46 04 eb 0a 8b 46 06 89 45 ba 66 8b 46 0a 66 89 42 0e 49 8b 47 08 <0f> b7 40 02 
83 e0 01 83 f8 01 19 d2 83 e2 04 83 c2 14 83 f8 01 

Message from syslogd@Cyrodiil at Jul 27 13:06:23 ...
 kernel: CR2: 0000000000002002

I'm not sure but it seems that there is a problem with SMP threading.

Thanx

Comment 3 Chuck Ebbert 2008-07-29 04:20:56 UTC
I think the problem is the madwifi driver...


Note You need to log in before you can comment on or make changes to this bug.