Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455711 - OpenOffice.org writer seems to crash randomly
Summary: OpenOffice.org writer seems to crash randomly
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 9
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-17 09:31 UTC by Steve Dowe
Modified: 2008-12-11 13:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-12-11 13:18:23 UTC


Attachments (Terms of Use)
Stack report (deleted)
2008-07-17 09:31 UTC, Steve Dowe
no flags Details
mapped stack (deleted)
2008-07-17 11:26 UTC, Caolan McNamara
no flags Details
Stack trace dumped by OOo when writer crashed. (deleted)
2008-07-31 14:41 UTC, Steve Dowe
no flags Details
replcement .so (deleted)
2008-08-01 08:24 UTC, Caolan McNamara
no flags Details
Trace dump after using new library file. (deleted)
2008-08-01 13:04 UTC, Steve Dowe
no flags Details
Stack trace (deleted)
2008-08-02 07:13 UTC, Steve Dowe
no flags Details
Another trace when using Ctrl-Shift-Left (deleted)
2008-08-02 07:31 UTC, Steve Dowe
no flags Details
another replacement .so (deleted)
2008-09-04 09:27 UTC, Caolan McNamara
no flags Details


Links
System ID Priority Status Summary Last Updated
OpenOffice.org 92343 None None None Never

Description Steve Dowe 2008-07-17 09:31:15 UTC
Description of problem:

At the time the crash occurred, I was holding Shift-Ctrl-> to highlight text one
word at a time.  My document contained only standard formatting elements, like
Heading styles and bullet points.

Version-Release number of selected component (if applicable):

openoffice.org-2.4.1-17.4.fc9

How reproducible:

Not easily. I can't offer definitive steps.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:


I have noticed this behaviour on x86_64 OOo before.  I reinstalled F9 but the 32
bit version, and seemed to have no problems. Since installing 64-bit again, this
crash occurs in writer.

Trace dump is attached.

Comment 1 Steve Dowe 2008-07-17 09:31:15 UTC
Created attachment 312023 [details]
Stack report

Comment 2 Caolan McNamara 2008-07-17 11:26:18 UTC
Created attachment 312033 [details]
mapped stack

Comment 3 Caolan McNamara 2008-07-17 11:30:23 UTC
The pattern fits some unsigned long event getting mangled through an unsigned
int type, but I don't see anything immediately wrong in the backtrace locations,
and that particular keystroke doesn't blow up OOo for me yet.

Comment 4 Caolan McNamara 2008-07-23 19:13:08 UTC
I don't suppose you happened upon a reproducible mechanism to get this crash ?

Comment 5 Steve Dowe 2008-07-23 20:41:13 UTC
Not yet, I'm afraid.  Leave it with me a couple more days and I'll try to hammer
it into submission :)

Comment 6 Steve Dowe 2008-07-31 14:41:18 UTC
Created attachment 313104 [details]
Stack trace dumped by OOo when writer crashed.

Comment 7 Steve Dowe 2008-07-31 14:42:57 UTC
Regarding the attachment (id 313104) - I managed to get a second crash. While
editing text, I deleted a small block (a few words) in one bullet point and used
"del"[ete] keye to bring up the following line to adjoin the end of this line. 
Then it crashed.

It seems to crash when I'm working quickly.  Possibly mouse pointer interaction
has something to do with this. Is it possible that some problem with the
radeon.so driver could be causing this?

Comment 8 Caolan McNamara 2008-07-31 16:04:13 UTC
I don't suppose that whacking any of the *other* keys around your delete key
reproduces this, i.e. occasional misses :-)

I can't reproduce, but at least I see one suspicious little thing in the vicinity.

Comment 9 Steve Dowe 2008-07-31 20:13:23 UTC
Oh yeah, it's ENTIRELY possible that I hit an adjacent key instead of the key I
intended to hit. :)

On my laptop keyboard, the DELETE key is top right corner.  INSERT / [prt scr]
is immediately left of it and HOME is south of it.  As the behaviour I observed
was my text being deleted, the only plausible key (mis-)press would be INSERT.

( [prt scr] above just indicates the key's mode if the function key is also
depressed. )

Is there anything further I can do to replicate this? E.g. certain key presses?

Comment 10 Caolan McNamara 2008-08-01 08:24:10 UTC
Created attachment 313168 [details]
replcement .so

Make sure to backup your old version of this file from
/usr/lib64/openoffice.org/program to somewhere safe, and stick this one in
there instead

Comment 11 Caolan McNamara 2008-08-01 08:34:22 UTC
My expectation that this will *fix* OOo is pretty much nil, but it might. It
might also give a different crash trace that might help me figure this out.

Comment 12 Steve Dowe 2008-08-01 13:04:23 UTC
Created attachment 313194 [details]
Trace dump after using new library file.

Ok, I hate to disappoint you, but it didn't fix it.  However, I observed
slightly different behaviour this time round.

I started up writer, created a new document and started typing the first
paragraph.  As before, I'd created two lines (heading on the first line, this
time), and used DEL[ete] to bring up the line below it.  However, it didn't
crash here.

I then held down CRTL while tapping Cursor-Right to move the cursor one word at
a time. There was a momentary pause when I did this - I thought it was going to
crash. But no. (Perhaps this is the crash twice bit you mentioned?)

Then, holding down CTRL, I also held down Shift and hit Cursor-Right to select,
one word at a time, a few words. Then it fell over.

Comment 13 Steve Dowe 2008-08-02 07:13:20 UTC
Created attachment 313261 [details]
Stack trace

This one happened when I hit ENTER twice to create a second paragraph.	The
document otherwise only contained one paragraph, with a few hyperlinks
sprinkled in my text and nothing else.

Comment 14 Steve Dowe 2008-08-02 07:31:58 UTC
Created attachment 313262 [details]
Another trace when using Ctrl-Shift-Left

.. and this one was when selecting some text using my favourite Ctrl-Shift-Left
arrow technique. :(

Comment 15 Steve Dowe 2008-08-07 08:06:38 UTC
Is there anything further I can do to help solve this? Happy to experiment with new libraries or whatever... :)

Comment 16 Caolan McNamara 2008-09-04 09:27:27 UTC
Created attachment 315730 [details]
another replacement .so

Well, this replacement .so is worth a shot to better identify the problem.

Afterwards if you run writer from a console it should print out at the start and end of each command triggered by a keystroke combo. So if it crashes then we should know what the last run command was, and the exception catching stuff has been disabled, so the crash report should report where the crash took place, rather than where the exception was caught and then crashed, which wasn't as useful

Comment 17 Vivian Bian 2008-09-10 02:38:37 UTC
Although I haven't reproduced the bug, but I'll show my step here.

The system info:
Fedora 9
kernel 2.6.25.14-108.fc9.x86_64 on an x86_64
openoffice: openoffice.org-2.4.1-17.4.fc9.x86_64

The step:
1.start up the writer via the Terminal,typing the oowriter.
2.typed two lines of words and also the bullet points there , and made the first line the Heading font type.
3.hold the Ctrl+Shift+ -> to highlight the words one by one.(I repeated this step for many times, but nothing happened)
4.just hold the Shift + -> to highlight the words one letter by one letter ,nothing happened.
5.just hold the Ctrl + -> to move among the words one by one, nothing ,either.
6.hold the Ctrl+Shift,and press the keys around the cursors ,such as the Del[ete],the PageDown,PageUp,Insert,RightCtrl,RightShift,Enter,End,Home,and also the PrtScrSysRq.When I changed the key from one to another fast, there was a pause, I thought it was the crash , but no.

So,I wondered whether it is a problem caused by the Memory,whether it is a problem caused by the Memory addressability?

Comment 18 Vivian Bian 2008-09-10 10:59:13 UTC
After update the openoffice to the latest version openoffice 2.4.1-17.6.fc9.x86_64
,I did the reproduce again , and have found nothing .

Comment 19 Caolan McNamara 2008-10-16 14:35:23 UTC
caolanm->steve.dowe@onecool.com: Re Comment #16, did you ever get a chance to try out that replacement debugging library to see if it would print out a hint as to the name of the command which was last triggered from the keyboard was before a crash ?

Comment 20 Steve Dowe 2008-10-28 12:51:09 UTC
Sorry, but due to productivity requirements I needed to install a vanilla 32-bit OOo instead.

But I still intend to try out the new library and get back to you on this. Will have to test via a VM instead now.

Comment 21 Caolan McNamara 2008-12-11 13:18:23 UTC
ok, lets forget about it and hope that its good in F-10


Note You need to log in before you can comment on or make changes to this bug.