Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455710 - TBd05087db rhnplugin.py:298:_noExceptionWrappingGet:UnboundLocalError:
Summary: TBd05087db rhnplugin.py:298:_noExceptionWrappingGet:UnboundLocalError:
Keywords:
Status: CLOSED DUPLICATE of bug 428323
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin
Version: 5.1.z
Hardware: i386
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: John Matthews
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-17 09:13 UTC by Vanborren Eric
Modified: 2008-09-18 19:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-18 19:00:32 UTC


Attachments (Terms of Use)
up2date asked to save the file (deleted)
2008-07-17 09:13 UTC, Vanborren Eric
no flags Details

Description Vanborren Eric 2008-07-17 09:13:00 UTC
Description of problem:
Component: Software Updater
Summary: TBd05087db rhnplugin.py:298:_noExceptionWrappingGet:UnboundLocalError:
local variable 'result' referenced before assignment


Version-Release number of selected component (if applicable):
[root@lnx1epr01 etc]# cat redhat-release
Red Hat Enterprise Linux Server release 5.1 (Tikanga)


How reproducible:
after up2date --register
under X, launch up2date


Steps to Reproduce:
1. after up2date --register
2. under X, launch up2date
3.
  
Actual results:
the system close the up2date windows

Expected results:
File "/usr/lib/yum-plugins/rhnplugin.py", line 298, in _noExceptionWrappingGet
    return result

Get all rpm in :
local: //var/cache/yum/rhel-i386-server-5/primary.xml.gz

Additional info:

Component: Software Updater
Summary: TBd05087db rhnplugin.py:298:_noExceptionWrappingGet:UnboundLocalError:
local variable 'result' referenced before assignment

Traceback (most recent call last):
  File "/usr/sbin/pup", line 668, in ?
    main()
  File "/usr/sbin/pup", line 664, in main
    pup.run()
  File "/usr/sbin/pup", line 499, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 274, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 159, in reposSetup
    self.doSackSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 331, in doSackSetup
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 203, in populateSack
    sack.populate(repo, with, callback, cacheonly)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 88, in populate
    xml = repo.getPrimaryXML()
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 635, in getPrimaryXML
    return self.retrieveMD('primary')
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 622, in retrieveMD
    cache=self.http_caching == 'all')
  File "/usr/lib/yum-plugins/rhnplugin.py", line 209, in _getFile
    start, end, copy_local, checkfunc, text, reget, cache)
  File "/usr/lib/yum-plugins/rhnplugin.py", line 298, in _noExceptionWrappingGet
    return result
UnboundLocalError: local variable 'result' referenced before assignment

Local variables in innermost frame:
remote:
https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-i386-server-5/repodata/primary.xml.gz
start: None
url: None
text: None
self: rhel-i386-server-5
cache: False
reget: None
server: https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-i386-server-5
relative: repodata/primary.xml.gz
headers: (('X-RHN-Auth-Expire-Offset', '3600.0'), ('X-RHN-Auth-User-Id', ''),
('X-RHN-Auth', 'NHewF4hl4uFZBSv6dgItmQ=='), ('X-RHN-Auth-Server-Time',
'1216284609.27'), ('X-RHN-Server-Id', 1013266807), ('Pragma', 'no-cache'))
checkfunc: (<bound method RhnRepo.checkMD of <rhnplugin.RhnRepo object at
0x9a1bbac>>, ('primary',), {})
copy_local: 1
end: None
local: //var/cache/yum/rhel-i386-server-5/primary.xml.gz

Comment 1 Vanborren Eric 2008-07-17 09:13:00 UTC
Created attachment 312017 [details]
up2date asked to save the file

Comment 2 John Matthews 2008-09-18 19:00:32 UTC

*** This bug has been marked as a duplicate of bug 428323 ***


Note You need to log in before you can comment on or make changes to this bug.