Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455701 - cpufreq driver get the wrong processor number in domain by ACPI _PSD table
Summary: cpufreq driver get the wrong processor number in domain by ACPI _PSD table
Keywords:
Status: CLOSED DUPLICATE of bug 428909
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.2
Hardware: x86_64
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Peter Martuccelli
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On: 428909
Blocks: 455516
TreeView+ depends on / blocked
 
Reported: 2008-07-17 09:05 UTC by Song, Youquan
Modified: 2008-08-15 19:09 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-14 19:56:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch for commit ID 152c300d007c70c4a1847dad39ecdaba22e7d457 (deleted)
2008-07-17 09:22 UTC, Song, Youquan
no flags Details

Description Song, Youquan 2008-07-17 09:05:49 UTC
Description of problem:

Hardware: Tylersburg HEDT, Nehalem, BIOS SOX5810J.86A.0977.2008.0624.2121.
RHEL5.2 cpufreq driver get the the processor number in domain equal "0" by 
ACPI _PSD table. Actually, ACPI _PSD table show the processor number in domain 
equal "8".  In other hand, FedoraCore 9 can get the correct processor number 
in domain equaling "8". Processor number in domain is important parameter for 
cpufreq driver and governor do SW/HW coordination.  

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Boot RHEL5.2
2. cat /sys/devices/system/cpu/cpu0/cpufreq/affected_cpus.
3. affected_cpus show "0". 
4. 
  
Actual results:


Expected results:


Additional info:

Comment 1 Song, Youquan 2008-07-17 09:16:27 UTC
I validation on the Tylersburg HEDT, the upstream patche can fix this bug. The 
commit ID 152c300d007c70c4a1847dad39ecdaba22e7d457.  




Comment 2 Song, Youquan 2008-07-17 09:22:28 UTC
Created attachment 312018 [details]
Patch for commit ID 152c300d007c70c4a1847dad39ecdaba22e7d457

Comment 3 Song, Youquan 2008-07-18 06:51:28 UTC
I can not access the 455516 bug.

Comment 4 John Villalovos 2008-07-25 13:29:21 UTC
This bug almost seems like a dupe of #428909 since the same patch solves both
issues.

Comment 5 Peter Martuccelli 2008-07-25 13:49:06 UTC
Build a brew kernel with the patch and have people test against bug 428909.  I
will mark this one as a duplicate depending on the test results.

Comment 6 Peter Martuccelli 2008-08-14 19:56:52 UTC

*** This bug has been marked as a duplicate of bug 428909 ***

Comment 7 John Villalovos 2008-08-15 17:28:40 UTC
Youquan,

Are there any BIOS settings which affect this?  I am trying to test on HEDT system with 0926 BIOS version

Comment 8 John Villalovos 2008-08-15 19:09:55 UTC
The BIOS on the system is SOX5810J.86A.1171.2008.0717.0926 so it is the 1171 BIOS.

Disregard BIOS revision I specified in Comment 7


Note You need to log in before you can comment on or make changes to this bug.