Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4557 - bugs in kde.csh in kdesupport-1.1.1-1
Summary: bugs in kde.csh in kdesupport-1.1.1-1
Keywords:
Status: CLOSED DUPLICATE of bug 3686
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdesupport
Version: 6.0
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-16 23:39 UTC by david_pedersen
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-18 15:28:41 UTC


Attachments (Terms of Use)

Description david_pedersen 1999-08-16 23:39:09 UTC
The file kde.csh has several defects. If I'm a user and
attempt to login to my machine, the sourcing of kde.csh will
fail...

list of bugs
[1] didn't use 'set' when specifying 'kdepath'
[2] final 'if...then' doesn't check exit status, instead
checks output of command 'echo $path | grep -q
$kdepath'..need to look at exit status by either using {}
around command or via the $status variable

Here is a script with the issues fixed...just do a diff with
original to see problems...
-----------

# KDE initialization script (csh)
if ( $?KDEDIR ) then
         if ( $KDEDIR == "/usr" ) then
         exit
         endif
endif
setenv KDEDIR /usr
set kdepath="${KDEDIR}/bin"

echo $path | grep $kdepath > /dev/null
if ( $status ) then
 exit
endif

setenv PATH "${kdepath}:${PATH}"

Comment 1 Jeff Johnson 1999-08-18 15:28:59 UTC
*** This bug has been marked as a duplicate of 3686 ***


Note You need to log in before you can comment on or make changes to this bug.