Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455697 - SELinux is preventing perl (logwatch_t) "getattr" to /root (user_home_dir_t)
Summary: SELinux is preventing perl (logwatch_t) "getattr" to /root (user_home_dir_t)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy
Version: 5.2
Hardware: i386
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-17 08:29 UTC by eric
Modified: 2009-01-20 21:32 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-20 21:32:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0163 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2009-01-20 16:05:21 UTC

Description eric 2008-07-17 08:29:04 UTC
Description of problem:
SELinux is preventing perl (logwatch_t) "getattr" to /root (user_home_dir_t). 

SELinux denied access requested by perl. It is not expected that this access is
required by perl and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access. 

Version-Release number of selected component (if applicable):
Source Context:  system_u:system_r:logwatch_t:SystemLow-SystemHigh
Target Context:  root:object_r:user_home_dir_t
Target Objects:  /root [ dir ]
Source:  0logwatch
Source Path:  /usr/bin/perl
Port:  <Unknown>
Host:  funexafs
Source RPM Packages:  perl-5.8.8-10.el5_2.3
Target RPM Packages:  filesystem-2.4.0-1
Policy RPM:  selinux-policy-2.4.6-137.1.el5_2
Selinux Enabled:  True
Policy Type:  targeted
MLS Enabled:  True
Enforcing Mode:  Enforcing
Plugin Name:  catchall_file
Host Name:  funexafs
Platform:  Linux funexafs 2.6.18-92.1.6.el5

How reproducible:
Once a day - every day

Comment 1 Ivana Varekova 2008-07-21 08:20:25 UTC
Daniel, could you please look at this.


Comment 2 Daniel Walsh 2008-07-24 13:01:37 UTC
This looks like logwatch is searching the /root directory for bad contents?

I will have a fix for this in selinux-policy-2.4.6-142.el5

For now it can be ignored.

Comment 9 errata-xmlrpc 2009-01-20 21:32:12 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0163.html


Note You need to log in before you can comment on or make changes to this bug.