Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455690 - [5.2] Kernel panic at radix_tree_lookup+0x4/0x51
Summary: [5.2] Kernel panic at radix_tree_lookup+0x4/0x51
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-17 05:52 UTC by Qian Cai
Modified: 2008-09-10 07:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-10 07:48:00 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Qian Cai 2008-07-17 05:52:05 UTC
Description of problem:
While removing and installing Kernel packages, the running Kernel panicked.
Unfortunately, I could not save the vmcore at that time.

[root@ibm-palmetto ~]# Unable to handle kernel paging request at
0000000095f97280 RIP: 
 [<ffffffff80144557>] radix_tree_lookup+0x4/0x51
PGD 25e84067 PUD 0 
Oops: 0000 [1] SMP 
last sysfs file: /block/ram0/dev
CPU 0 
Modules linked in: autofs4 hidp rfcomm l2cap bluetooth sunrpc ipv6 xfrm_nalgo
crypto_api dm_multipath video sbs backlight i2c_ec button battery asus_acpi
acpi_memhotplug ac parport_pc lp parport floppy sg i6300esb ide_cd serio_raw
cdrom pcspkr shpchp i2c_i801 i2c_core e1000 dm_snapshot dm_zero dm_mirror dm_mod
ata_piix libata sd_mod scsi_mod ext3 jbd uhci_hcd ohci_hcd ehci_hcd
Pid: 2962, comm: modprobe Tainted: G   M  2.6.18-92.el5 #1
RIP: 0010:[<ffffffff80144557>]  [<ffffffff80144557>] radix_tree_lookup+0x4/0x51
RSP: 0000:ffff810022819d20  EFLAGS: 00010012
RAX: 0000000022b79650 RBX: 0000000000000000 RCX: ffff810001000020
RDX: 0000000022b79650 RSI: 0000000000000000 RDI: ffff81003ec36e20
RBP: ffff81003ec36e18 R08: ffff810037ff9d85 R09: 00000000000260e8
R10: 0000000000000000 R11: ffff81003f566040 R12: 0000000000000000
R13: ffff81003f96d780 R14: ffff81003ec36e00 R15: ffff81003f96d7e8
FS:  0000000000000000(0000) GS:ffffffff8039e000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 0000000095f97280 CR3: 0000000023878000 CR4: 00000000000006e0
Process modprobe (pid: 2962, threadinfo ffff810022818000, task ffff81003f566040)
Stack:  ffffffff8000769e 00000010000284d0 0000000000000000 ffff81003ec36e00
 ffffffff80007692 ffffffff00000001 ffff810027ae96b8 0000000000000000
 ffffffff80013248 ffff81002387b1d8 ffff810022819e24 ffff810022b79608
Call Trace:
 [<ffffffff8000769e>] find_get_page+0x21/0x50
 [<ffffffff80007692>] find_get_page+0x15/0x50
 [<ffffffff80013248>] filemap_nopage+0xab/0x322
 [<ffffffff80008848>] __handle_mm_fault+0x1f8/0xe23
 [<ffffffff8006681f>] do_page_fault+0x4cb/0x830
 [<ffffffff8001c750>] vma_link+0xd0/0xfd
 [<ffffffff8000dde2>] do_mmap_pgoff+0x66c/0x7d7
 [<ffffffff8005dde9>] error_exit+0x0/0x84


Code: 48 3b 34 c5 00 c0 3c 80 77 40 85 d2 75 0b 48 83 7f 08 00 48 
RIP  [<ffffffff80144557>] radix_tree_lookup+0x4/0x51
 RSP <ffff810022819d20>
CR2: 0000000095f97280
 <0>Kernel panic - not syncing: Fatal exception

Version-Release number of selected component (if applicable):
RHEL5-Server-U2 GA tree
kernel-2.6.18-92.el5

How reproducible:
Seen once on ibm-palmetto.rhts.bos.redhat.com

Additional info:
Running commands at the time of panic,

[root@ibm-palmetto ~]# rpm -e kernel-debug-2.6.18-92.1.6.el5
rpm -ivh [root@ibm-palmetto ~]# rpm -ivh kernel-debug-2.6.18-92.1.6.el5.x86_64.rpm
Preparing...                ########################################### [100%]
   1:kernel-debug           ########################################### [100%]

Comment 1 Qian Cai 2008-08-04 06:45:51 UTC
I hit this problem several times. Some happened after cold reset, some during normal circumstances. There was a vmcore saved during the overnight,

INIT: version 2.86 reloading^M^M
Unable to handle kernel paging request at 000000017f7f5180 RIP:
 [<ffffffff80144557>] radix_tree_lookup+0x4/0x51


http://porkchop.devel.redhat.com/qa/qa/qcai/vmcores/vmcore-455690

Comment 2 Qian Cai 2008-09-10 07:48:00 UTC
Looks like hardware issues.


Note You need to log in before you can comment on or make changes to this bug.