Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455689 - Local overide files and dirs only allow 3 digit Modes
Summary: Local overide files and dirs only allow 3 digit Modes
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Configuration Management
Version: 421
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Partha Aji
QA Contact: Brandon Perkins
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-17 04:59 UTC by Jason Tan
Modified: 2008-12-18 18:26 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-12-18 18:26:25 UTC


Attachments (Terms of Use)

Description Jason Tan 2008-07-17 04:59:30 UTC
Description of problem:

In satellite if  you want to set an override file/dir in the
Configuration->Local Overides->Add File/Dir you can only set a 3 char digit
Mode, e.g. 775.
This means it is not possible to set  modes with setuid,setgid or the sticky bit
set.

An example of why you might want to do this is the /var/www/html dir in the
httpd package.
You may want to set that dir with a mode/owernsip liek this:

drwxrwsr-x  12 root buzz-content 4096 Jul 17 13:13 /var/www/html

so that members of the buzz-content group can add/modify/remove files in the dir.

When you upgrade httpd however the mode is lost and it is not possible to
override it correctly in the Mode of the Local Overides, because to do you would
would need to set the Mode to 2775 and it is not possible to do that as the text
field only accepts 3 chars.

This means that after every system update/upgrade you need to remember to reset
the mode of the dir.

We have this problem on a number of systems.

Version-Release number of selected component (if applicable):
Redhat Satellite 4.2.1 running on REHL 4-5.

How reproducible:

Reliably reporducable

Steps to Reproduce:
1. Log into satellite.
2. Select a a host
3. Click the "Configuration" tab
4. Click the "Local Overides" link
5. Click "add directories" link.
6. Place cursor into "Mode" text field and attempt to enter the text "2775".
 
Actual results:
You will only be able to enter "277"

Expected results:

You should be able to enter "2775" or another 4 digit string.


Additional info:

Phone number is +61 410 114 192 timezone is +9.5 feel free to call if that would
be useful.


Note You need to log in before you can comment on or make changes to this bug.