Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455688 - build in web browser always shows blank page
Summary: build in web browser always shows blank page
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: conduit
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Michel Alexandre Salim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-17 04:15 UTC by Hiran Arias
Modified: 2008-09-23 03:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-23 03:27:44 UTC


Attachments (Terms of Use)

Description Hiran Arias 2008-07-17 04:15:38 UTC
Description of problem:

Failed to use data providers that requires built web browser and to open
Help->Developer links, the new windows always open in blank.

Version-Release number of selected component (if applicable):
conduit-0.3.11.1

How reproducible:

Fresh install

Steps to Reproduce:
1. Install conduit
2. Install gnome-phyton2-gtkmozembed
3. Try to sync facebook or open the Help->Development links
  
Actual results:

The new windows always open in blank

Expected results:


Additional info:

Found out that the gtkmozembed.so library was compiled using xulrunner and not
firefox, and that the script /usr/bin/conduit has a work around to find the
run-mozilla.sh script just for firefox, modifying the script to use xulrunner
instead solves the problem.

Comment 1 Michel Alexandre Salim 2008-08-23 06:37:00 UTC
I just fixed this for the 0.3.13 package. I'm also switching the rendering engine that conduit uses to "system" (using the default system browser), since on Fedora 9 and Rawhide, using Firefox 3/xulrunner 1.9, conduit crashes when opening a second help page.

Comment 2 Fedora Update System 2008-08-23 06:49:33 UTC
conduit-0.3.13-1.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/conduit-0.3.13-1.fc8

Comment 3 Fedora Update System 2008-08-23 06:50:19 UTC
conduit-0.3.13-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/conduit-0.3.13-1.fc9

Comment 4 Fedora Update System 2008-09-10 07:07:41 UTC
conduit-0.3.13-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update conduit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7328

Comment 5 Fedora Update System 2008-09-10 07:11:51 UTC
conduit-0.3.13-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update conduit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-7625

Comment 6 Michel Alexandre Salim 2008-09-23 03:27:44 UTC
0.3.13-2 is in testing and fixes some packaging bug; push to stable requested. Closing this bug.


Note You need to log in before you can comment on or make changes to this bug.