Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455679 - gnome-mouse-properties lose mouse sensetivity
Summary: gnome-mouse-properties lose mouse sensetivity
Keywords:
Status: CLOSED DUPLICATE of bug 474758
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-16 23:32 UTC by Alexey Kuznetsov
Modified: 2018-04-11 15:35 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-04-25 15:42:23 UTC


Attachments (Terms of Use)

Description Alexey Kuznetsov 2008-07-16 23:32:05 UTC
after setting mouse sensetivity do suspend/resume your machine. as result you
lose sensetivity for pointer (control value in dialog preserve).

same for connect/disconnect mouse - you lose settings for device (dialog value
preserve)

Comment 1 Didier 2008-11-19 09:33:48 UTC
I did not change other mouse settings, but I can confirm that gnome-mouse-properties looses the "Left-handed/Right-handed Mouse Orientation" setting ; the value is erroneously preserved in the dialogue window.


Experiencing this since F10-Beta, on at least two workstations, and up to current control-center-2.24.0.1-9.fc10.x86_64 .

This not only happens after a suspend/resume or hibernate cycle (100% reproducable), but also seems to occur after an undefined amount of time in screensaver.


This leads to several reassignments a day, which IMO seriously detriments user experience (after all, the mouse is a primary input device) ; I hope this gets fixed before F10-Final (with thousands of left-handed users).

Comment 2 Ray Strode [halfline] 2008-11-19 14:36:34 UTC
Unfortunately those won't get fixed for F10-Final.  We've missed that boat.  Could potentially get fixed in an F10 update though.

My guess is this is fallout from evdev.  When we suspend-resume the input device gets forgotten and readded as a hotplug event and so the pointer mapping is getting reset.

We probably need to be listening for new devices in gnome-settings-daemon and update the pointer mapping on them, and I bet we aren't.

Just a guess.

Comment 3 Matěj Cepl 2008-11-30 15:26:20 UTC
I suspect gnome-settings-daemon hasn't survived suspend/resume cycle -- I have same problem. Looks like duplicate of bug 466599 to me.

Comment 4 Didier 2008-11-30 18:28:31 UTC
WRT comment #3 : I also experience this problem after an extended (say 30 minutes) screensaver period : i.e. no suspend/resume cycle involved.

Comment 5 Ray Strode [halfline] 2008-12-01 21:46:26 UTC
is gnome-settings-daemon still running?

My guess is this is related to using evdev for devices.  on resume the existing devices probably generate new hotplug events and get seen as new devices so their old settings aren't applied.  There's another bug about that somewhere, I believe, that we should probably dupe this one to.

Comment 6 Didier 2008-12-02 12:58:38 UTC
When resuming from a hibernation, /usr/libexec/gnome-settings-daemon is still running.

I also wonder whether/how gnome-screensaver can invoke the loss of settings. How could one trace or monitor at what time a certain settings gets accessed ? Would putting an strace on gnome-settings-daemon be reasonable ? If yes, with what parameters ?

Comment 7 Ray Strode [halfline] 2008-12-02 18:32:01 UTC
i don't think that would work.  I think the issue is gnome-settings-daemon isn't listening for "new device" events and applying the existing settings to new devices.  I think it would be hard to decode what's going on from an strace.

Not sure why gnome-screensaver alone causes the problem.

Comment 8 Didier 2008-12-05 19:32:29 UTC
Killing and restarting gnome-settings-daemon restores mouse settings.

Comment 9 Didier 2008-12-19 08:19:05 UTC
Running :

kernel-2.6.27.7-134.fc10.x86_64
xorg-x11-drv-evdev-2.0.7-3.fc10.x86_64
control-center-2.24.0.1-9.fc10.x86_64
gnome-settings-daemon-2.24.1-3.fc10.x86_64 ,

the issue from comment #1 (mouse left/right hand settings lost after suspend/resume) seems to be resolved.

Comment 10 Alexey Kuznetsov 2008-12-19 09:23:06 UTC
confirm. connect/disconnect mouse also work

Comment 11 Bastien Nocera 2009-04-25 15:42:23 UTC
bug 474758 is the one. It's fixed in gnome-settings-daemon-2.24.1-7.fc10

*** This bug has been marked as a duplicate of bug 474758 ***


Note You need to log in before you can comment on or make changes to this bug.