Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455661 - No sound via pulseaudio. ALSA works
Summary: No sound via pulseaudio. ALSA works
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 9
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-16 20:49 UTC by Thomas Meyer
Modified: 2008-09-24 12:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-24 12:56:09 UTC


Attachments (Terms of Use)
Pulseaudio log (deleted)
2008-07-16 20:49 UTC, Thomas Meyer
no flags Details
card0 codec (deleted)
2008-07-16 20:52 UTC, Thomas Meyer
no flags Details

Description Thomas Meyer 2008-07-16 20:49:08 UTC
Description of problem:
No sound with pulseaudio.

Killing pulseaudio task, makes totem work again (while falling back to ALSA).

See attached logs.

Version-Release number of selected component (if applicable):
$ yum info pulseaudio
Geladene Plugins: refresh-packagekit
Installierte Pakete
Name       : pulseaudio
Architektur : i386
Version    : 0.9.10

$ yum info gstreamer
Geladene Plugins: refresh-packagekit
Installierte Pakete
Name       : gstreamer
Architektur : i386
Version    : 0.10.19

$ yum info totem
Geladene Plugins: refresh-packagekit
Installierte Pakete
Name       : totem
Architektur : i386
Version    : 2.23.2

How reproducible:
Always.

Steps to Reproduce:
1. Login to gnome
2. Try to play song in totem
3. 
  
Actual results:
No sound.

Expected results:
Sound.

Additional info:

Comment 1 Thomas Meyer 2008-07-16 20:49:08 UTC
Created attachment 311998 [details]
Pulseaudio log

Comment 2 Thomas Meyer 2008-07-16 20:52:40 UTC
Created attachment 311999 [details]
card0 codec

Comment 3 Thomas Meyer 2008-07-16 20:53:01 UTC
$ cat /proc/asound/cards
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfeaf0000 irq 21
 1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfebec000 irq 19



Comment 4 Lennart Poettering 2008-08-06 14:08:08 UTC
Please explain what you mean by "no sound"? Do you get an error message? Does the application freeze? Or does it appear to play properly but you just can't hear anything?

If it is the latter then you probably just have a volume control initialization probelm. Please rung "alsamixer -c0" in a terminal and play around with the controls.

Comment 5 Thomas Meyer 2008-08-09 12:15:47 UTC
(In reply to comment #4)
> Please explain what you mean by "no sound"? Do you get an error message?

No error message.

> Does the application freeze? 
No. E.g. Totem starts to play an MP3 file. The progress bar is moving very quickly (as the time), but no sound to hear.

> Or does it appear to play properly but you just can't  hear anything?

It appears to play, but time is moving very quickly. And i cannot hear anything.

> If it is the latter then you probably just have a volume control initialization
> probelm. Please rung "alsamixer -c0" in a terminal and play around with the
> controls.

Mixer controls are ok, because as i already wrote, when killing pulseaudio the gstreamer framework is falling back to ALSA, which works correctly.

One more thing i notcied: the error happens with the current Fedora kernel, i.e. 2.6.25.11-97.fc9.

Using kernel e.g. next-20080807 and the above error is gone.

Maybe this is some driver issue in the linux kernel, as there have been alsa updates between thoose two kernels.

Comment 6 Lennart Poettering 2008-09-09 19:51:17 UTC
Please set "log-level=debug" in /etc/pulse/daemon.conf

Then log out and back in. Check if things work. Post the syslog output of PA here.

Thanks!

Comment 7 Thomas Meyer 2008-09-13 08:30:24 UTC
Just received the fedora kernel update to 2.6.26.3-29.fc9.i686.PAE.

And with this update the described problems vanished.

Shall i still try to get the debug log for you?

From my side this bug can be closed.

Comment 8 Lennart Poettering 2008-09-24 12:56:09 UTC
Closing.


Note You need to log in before you can comment on or make changes to this bug.