Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455659 (gxine-needs-gecko) - Broken dependency on the gxine package
Summary: Broken dependency on the gxine package
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: gxine-needs-gecko
Product: Fedora EPEL
Classification: Fedora
Component: gxine
Version: el5
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Martin Sourada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-16 20:37 UTC by Andrea
Modified: 2008-08-01 08:26 UTC (History)
0 users

Fixed In Version: 0.5.11-16.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-01 08:12:50 UTC


Attachments (Terms of Use)

Description Andrea 2008-07-16 20:37:59 UTC
Description of problem:
The gxine package needs package gecko-libs, which is missing.

Version-Release number of selected component (if applicable):
0.5.11-14.el5

How reproducible:
By trying to install the gxine package with yum.

Steps to Reproduce:
1. yum install gxine
  
Actual results:
Error: Missing Dependency: gecko-libs = 1.8.0.12 is needed by package gxine

Expected results:
Successful installation of the gxine package and its dependencies.

Additional info:

Comment 1 Martin Sourada 2008-07-16 20:51:18 UTC
What version firefox do you have installed?

Comment 2 Andrea 2008-07-16 21:06:00 UTC
(In reply to comment #1)

I'm using Opera 9.51 on Scientific Linux 5.1.

Comment 3 Martin Sourada 2008-07-16 21:16:41 UTC
(In reply to comment #2)
> I'm using Opera 9.51 on Scientific Linux 5.1.
Aah, sorry, I should have formuled my question better. The gecko-lib dependency
is firefox, in Fedora 9 xulrunner. It's needed for js. Firefox in RHEL 5.1
should provide also gecko Provides, in RHEL 5.2 and Fedora 9 it is xulrunner
that provides this (though with different version). Therefore I asked, which
firefox do you have. Better would be asking, which firefox, or xulrunner, is
available in your repos.


Comment 4 Andrea 2008-07-16 22:04:32 UTC
No problem. Do you mean that package gecko-libs should be in Scientific Linux's base 
repositories?

As to Firefox and Xulrunner versions, I'll paste output from yum query:

-----BEGIN YUM QUERY-----
~# yum info firefox xulrunner
Loading "protectbase" plugin
Loading "kernel-module" plugin
578 packages excluded due to repository protections
Available Packages
Name   : firefox
Arch   : i386
Version: 3.0
Release: 2.el5
Size   : 9.3 M
Repo   : sl-testing
Summary: Mozilla Firefox Web browser
Description:
Mozilla Firefox is an open-source web browser, designed for standards
compliance, performance and portability.

Name   : xulrunner
Arch   : i386
Version: 1.9
Release: 1.el5
Size   : 10 M
Repo   : sl-testing
Summary: XUL Runtime for Gecko Applications
Description:
XULRunner provides the XUL Runtime environment for Gecko applications.

~# 
------END YUM QUERY------


Comment 5 Martin Sourada 2008-07-16 23:18:47 UTC
Thanks for the info. The problem was indeed in the new firefox. I've just
rebuild the gxine for the new xulrunner based gecko installation. It should be
pushed to the repos, hopefully, in less than a week.



Comment 6 Andrea 2008-07-17 00:06:23 UTC
That's great, thank you very much Martin.


Comment 7 Andrea 2008-08-01 08:00:50 UTC
Still no luck with this...

Comment 8 Martin Sourada 2008-08-01 08:12:50 UTC
It's in updates testing and today it's been pushed to stable updates:

https://www.redhat.com/archives/epel-devel-list/2008-August/msg00000.html

After your mirrors sync with the master repo, you should be able to update.

Comment 9 Andrea 2008-08-01 08:26:05 UTC
Cool, thanks again Martin.



Note You need to log in before you can comment on or make changes to this bug.