Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455658 - error running pup to update system
Summary: error running pup to update system
Keywords:
Status: CLOSED DUPLICATE of bug 446835
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut
Version: 5.4
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-16 20:37 UTC by Byron Rendar
Modified: 2013-01-10 10:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-16 21:03:39 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Byron Rendar 2008-07-16 20:37:48 UTC
Description of problem: trying to apply updates with package updater or pup I
get Metadata file does not match checksum


Version-Release number of selected component (if applicable):


How reproducible: run pup or click on updates available when it comes up


Steps to Reproduce:
1.pup
2.
3.
  
Actual results:Component: pirut
Summary: TB04230791 rhnplugin.py:299:_getFile:RepoError: failed to retrieve
repodata/updateinfo.xml.gz from rhel-i386-server-vt-5
error was [Errno -1] Metadata file does not match checksum

Traceback (most recent call last):
  File "/usr/sbin/pup", line 617, in ?
    main()
  File "/usr/sbin/pup", line 613, in main
    pup.run()
  File "/usr/sbin/pup", line 451, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 291, in doRefresh
    self.populateUpdates()
  File "/usr/sbin/pup", line 347, in populateUpdates
    self.updateMetadata.add(repo)
  File "/usr/lib/python2.4/site-packages/yum/update_md.py", line 265, in add
    md = obj.retrieveMD(mdtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 867, in retrieveMD
    cache=self.http_caching == 'all')
  File "/usr/lib/yum-plugins/rhnplugin.py", line 299, in _getFile
    raise yum.Errors.RepoError, \
RepoError: failed to retrieve repodata/updateinfo.xml.gz from rhel-i386-server-vt-5
error was [Errno -1] Metadata file does not match checksum

Local variables in innermost frame:
e: [Errno -1] Metadata file does not match checksum
url: None
text: None
self: rhel-i386-server-vt-5
cache: False
reget: None
relative: repodata/updateinfo.xml.gz
start: None
checkfunc: (<bound method RhnRepo.checkMD of <rhnplugin.RhnRepo object at
0xa39766c>>, ('updateinfo',), {})
copy_local: 1
end: None
local: //var/cache/yum/rhel-i386-server-vt-5/updateinfo.xml.gz



Expected results: ability to update system


Additional info:

Comment 1 James Antill 2008-07-16 21:03:39 UTC

*** This bug has been marked as a duplicate of 446835 ***


Note You need to log in before you can comment on or make changes to this bug.