Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455657 - prompts for auth user and password even when they're in the config
Summary: prompts for auth user and password even when they're in the config
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: twinkle
Version: 10
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-16 20:17 UTC by Jeremy Katz
Modified: 2009-09-14 16:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-14 16:14:56 UTC


Attachments (Terms of Use)

Description Jeremy Katz 2008-07-16 20:17:32 UTC
I have my authorization user and password in ~/.twinkle/foo.cfg but still get
prompted for the username and password when registering to the SIP server

Comment 1 Kevin Fenzi 2008-07-16 22:40:08 UTC
Under Setup -> System Settings -> General
is 'foo' checked to be a startup profile?

And under Setup -> User Profile -> foo
is the SIP authentication section correctly filled out? 
Note that you need to make sure the realm is right for some servers or it just
rejects your auth. 

Also, anything useful under ~/.twinkle/twinkle.log for a failed startup?

Comment 2 Jeremy Katz 2008-07-17 01:24:19 UTC
Yes and yes.  The realm must be right since when I then type in the username and
password again, it registers fine.

In the log file, it's just not doing an authorization pass at all the first time
before it asks for the username/pass

Comment 3 Kevin Fenzi 2008-07-29 02:49:45 UTC
Does the twinkle.log say it's reading foo.cfg ?
Are there any REGISTER SIP requests showing up in there on startup?

I assume permissions are ok on the foo.cfg file(s)?

I'm pretty puzzled by this as my setup here registers me with 3 providers on
startup with no issues. ;( 

Comment 4 Jeremy Katz 2008-07-29 03:03:05 UTC
Yep, it says its reading the config.  And I see it with my config for
talk.fp.org also.  With my talk.fp.org account, ~/.twinkle/fedora.cfg starts out
with
# USER
user_name=katzj
user_domain=talk.fedoraproject.org
user_display=Jeremy Katz
user_organization=
auth_realm=talk.fedoraproject.org
auth_name=katzj
auth_pass=<PASSWORDHERE>

I'll attach the twinkle log from it.  But everything looks reasonable to me :-/

Comment 6 Kevin Fenzi 2008-08-12 00:34:38 UTC
Do you have: 
register_at_startup=yes

in the cfg file? 

Also, can you attach the twinkle.log?

Comment 7 Jeremy Katz 2008-08-12 00:40:13 UTC
Yep :-/

Comment 8 Kevin Fenzi 2008-09-03 20:21:35 UTC
I realize this would be slightly black magic, but could you try the 1.3.2 version I just built for rawhide? 

http://koji.fedoraproject.org/koji/taskinfo?taskID=802992

Comment 9 Jeremy Katz 2008-09-04 03:13:47 UTC
Doesn't help and nothing appears different to me in the log :(

Comment 10 Bug Zapper 2008-11-26 02:34:07 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 11 Kevin Fenzi 2009-03-04 20:37:56 UTC
A completely random plea to try the 1.4.2 currently in rawhide?

Comment 13 Tom "spot" Callaway 2009-09-14 16:14:56 UTC
Jeremy is gone, closing this bug out as I am not in the position to reproduce.


Note You need to log in before you can comment on or make changes to this bug.