Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455640 - Cannot save messages into INBOX on local spool
Summary: Cannot save messages into INBOX on local spool
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: alpine
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Joshua Daniel Franklin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-16 18:44 UTC by Ben Webb
Modified: 2008-09-25 00:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-11 21:22:39 UTC


Attachments (Terms of Use)

Description Ben Webb 2008-07-16 18:44:06 UTC
Description of problem:
When running alpine on our mail server (i.e. INBOX is /var/spool/mail/ben and
other folders are in ~ben/mail/) it is impossible to save a message into INBOX
(i.e. /var/spool/mail/ben); instead, it is saved into ~ben/mail/inbox.

Version-Release number of selected component (if applicable):
alpine-1.10-4.fc9.i386

How reproducible:
Always.

Steps to Reproduce:
1. Run alpine on the mail server, i.e. accessing inbox in /var/spool/mail/ben
and other folders in ~ben/mail/ directly, NOT via IMAP or POP.
2. Hit L to get the folder list, then select a folder other than INBOX. 
3. Select a message from this folder, hit S to save it, and put in INBOX as the
folder.
  
Actual results:
Alpine complains that:
"Folder "inbox" doesn't exist. Create?"
If you hit N, the save fails. If you hit Y, the message is saved into
~ben/mail/inbox.

Expected results:
No prompt is given (since INBOX exists, of course). The message is saved into
/var/spool/mail/ben.

Additional info:
Note that alpine *does* know about INBOX. You can select the folder from the
folder list (and get the actual inbox). When saving the message you can use tab
completion, and it'll correctly fill in INBOX for you, or you can use ^T to get
a list of folders and select INBOX from that. But the end result is the same -
it tries to make a new folder called inbox to put the message in.

Clearly alpine is not supposed to work this way, since if you connect via IMAP
(even to localhost) you *can* save messages back into INBOX correctly. So either
alpine should work in the same fashion for local spool, or if saving to inbox
isn't possible for some reason, it should not allow you to select that mailbox
in the first place!

Our users report that they used to be able to save messages back into INBOX in
this fashion with our previous pine RPM (from the Dag repo).

Comment 1 Rex Dieter 2008-07-16 18:56:20 UTC
I could be wrong, but I don't think pine or alpine ever supported saving to
/var/spool/...  

For our local site, a work around is to create an INBOX in users' home directory.  
install uw-imap-utils and (as the user) create a mix folder
$ mailutil create '#driver.mix/INBOX'

Comment 2 Rex Dieter 2008-07-16 18:57:38 UTC
When an inbox lives in the users' homedir, new mail gets moved there before
reading (when using imap anyway).  Well, when using uw-imap anyway.

Comment 3 Jima 2008-07-16 19:03:53 UTC
Ben: Have you tried hitting Control-P while in the Save dialog?  I think that
*might* do it.

Comment 4 Jima 2008-07-16 19:06:39 UTC
Oh, maybe that only works when you have multiple incoming folders defined. 
Rats.  However, I'm not sure this is a Fedora-specific issue.

Comment 5 Ben Webb 2008-07-16 19:30:38 UTC
Thanks for the followup! Regarding comment #1, I said in the original bug report
that pine *did* support saving to /var/spool/ - although it's entirely possible
this was a Dag-specific patch rather than something in Pine upstream. We can't
use the proposed workaround because that would confuse the IMAP clients that
some of our users also use. I also don't want to mess with our mail system to
placate one broken client.

Regarding comment #4, sure, it may not be Fedora specific, in which case this
can be pushed upstream.

For now, I can train my users that "saving into INBOX doesn't work" so that they
don't do it (or they use mutt). But it would be nice if Alpine either allowed it
or didn't tab-complete to INBOX or show it when I hit ^T if it's not going to
let me save there.

Comment 6 Joshua Daniel Franklin 2008-07-17 00:24:04 UTC
I might also suggest asking on the alpine-info mailing list. I also have never
used alpine to access /var/spool/mail/$USER but I think some others do that. 

Rex or Jima, care to own this bug?

Comment 7 Ben Webb 2008-07-18 18:39:48 UTC
I've reported the problem upstream on alpine-info:
http://mailman1.u.washington.edu/pipermail/alpine-info/2008-July/001009.html

Comment 8 Joshua Daniel Franklin 2008-09-10 17:48:03 UTC
It is not clear to me whether the alpine dev team got to this bug, but they did say they were working on it:

http://mailman2.u.washington.edu/pipermail/alpine-info/2008-July/001009.html

So, would you mind testing against alpine 2.00:

su -c 'yum --enablerepo=updates-testing update alpine' 

You can provide feedback for the update here:
http://admin.fedoraproject.org/updates/F8/FEDORA-2008-7290

Please let me know if this fixes the bug. If you find any
unrelated bug, please file on the alpine 2.00 update bugzilla:

https://bugzilla.redhat.com/show_bug.cgi?id=460332#c14

Comment 9 Ben Webb 2008-09-11 20:18:58 UTC
According to http://www.washington.edu/alpine/changes/1.10-to-2.00.html it looks like they did fix it:

   Bugs that have been addressed in this release include:
...
     *  Save to a local default INBOX failed if the primary collection
        was also local, which it is by default. The save went to
        ~/mail/inbox instead.

I just tested the update on our system, and it works for us.

Comment 10 Joshua Daniel Franklin 2008-09-11 21:22:39 UTC
Yipee! Thanks for report, I love closing fixed bugs.

Comment 11 Fedora Update System 2008-09-25 00:25:31 UTC
alpine-2.00-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.