Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455633 - firefox not functional when places.sqlite* is corrupted
Summary: firefox not functional when places.sqlite* is corrupted
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-16 18:12 UTC by Rik van Riel
Modified: 2018-04-11 12:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-16 19:23:10 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Mozilla Foundation 445565 None None None Never

Description Rik van Riel 2008-07-16 18:12:07 UTC
Description of problem:

When my system was powered off (something fell on the power bar switch), firefox
left an inconsistent places.sqlite* in place.

After reboot and restarting firefox, the following things were broken:
- no working back button, reload button or stop button
- urls were not displayed in the url bar (except the last url typed)
- no working "back" functionality in the browser
- every tab was shown as "loading" (spinning loader thingy), the favicon was
never shown

Version-Release number of selected component (if applicable):

firefox-3.0-1.fc9.i386

Steps to Reproduce:
1. start up firefox with a broken places.sqlite* (in my case,
places.sqlite-journal was 0 size)
2. suffer all kinds of bugs and missing functionality
  
Expected results:

The browser should detect that places.sqlite* is inconsistent.  Maybe it could
reinitialize the places.sqlite*, since removing those files restored firefox to
its former glory - everything now works again.

Additional info:

Removing places.sqlite* makes firefox work again like it should.

Comment 1 Matěj Cepl 2008-07-16 19:23:10 UTC
We found that this bug has been already registered in the upstream database
(https://bugzilla.mozilla.org/show_bug.cgi?id=445565) and believe that it is
more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug
tracker, and will review any bug fixes that become available for consideration
in future updates.

Thank you for the bug report.

Comment 2 Matěj Cepl 2008-07-16 22:06:50 UTC
Rik, could you please add yourself to the upstream bug?
https://bugzilla.mozilla.org/show_bug.cgi?id=445565#c1


Note You need to log in before you can comment on or make changes to this bug.