Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455623 - Cannot install KDM Themes
Summary: Cannot install KDM Themes
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase-workspace
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-16 17:33 UTC by Colin J Thomson
Modified: 2008-09-10 07:19 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-01 19:50:56 UTC


Attachments (Terms of Use)

Description Colin J Thomson 2008-07-16 17:33:35 UTC
Description of problem:
Cannot install KDM Themes locally or via the download option.

Version-Release number of selected component (if applicable):
KDE-4.1rc1 Version 4.00.98 (KDE 4.0.98) (kde-redhat)

How reproducible:
always

Steps to Reproduce:
1.try to install a theme, locally or via download.
2.
3.
  
Actual results:
Before the theme manager opens I am presented with this:
Unable to create folder /usr/share/apps/kdm/themes
Unable to create folder /usr/share/apps/kdm/faces
I can then proceed to download and install a Theme but it it fails. This has
been apparent since kde-4.x

Expected results:
Should be able to install a Theme locally or via the net

Additional info:Comment from Rex Dieter "Theme manager should be looking in
/usr/share/kde4/apps/kdm/"

Comment 1 Chitlesh GOORAH 2008-07-18 06:27:19 UTC
kdmtheme is no longer available in F9.

This bug report is targeted to kdebase.

Comment 2 Kevin Kofler 2008-07-27 14:38:35 UTC

*** This bug has been marked as a duplicate of 456004 ***

Comment 3 Kevin Kofler 2008-07-31 23:38:57 UTC
I think this is probably better to track separately after all, so I reopened 
this bug.

Colin J Thomson writes:
> Still seeing a problem here:
> Unable to create folder /usr/share/apps/kdm/themes
> Unable to create folder /usr/share/apps/kdm/faces
> So Themes cannot be installed as per comments in bug #455623
> rpm -qa|grep kdelibs
> kdelibs-devel-4.1.0-2.fc9.i386
> kdelibs-4.1.0-2.fc9.i386
> kdelibs3-devel-3.5.9-16.fc9.i386
> kdelibs-common-4.1.0-2.fc9.i386
> kdelibs3-3.5.9-16.fc9.i386

Comment 4 Kevin Kofler 2008-07-31 23:44:02 UTC
What I don't understand is why the new kstandarddirs patch isn't fixing this.

Comment 5 Colin J Thomson 2008-07-31 23:59:02 UTC
FYI:
[g6avk@localhost ~]$ ls -la /usr/share/kde4/apps/kdm
total 32
drwxr-xr-x   8 root root 4096 2008-07-28 20:21 .
drwxr-xr-x 198 root root 4096 2008-07-29 17:52 ..
drwxr-xr-x   2 root root 4096 2008-07-29 17:49 faces
drwxr-xr-x   2 root root 4096 2008-07-29 17:49 patterns
drwxr-xr-x   3 root root 4096 2008-07-29 17:49 pics
drwxr-xr-x   2 root root 4096 2008-07-29 17:49 programs
drwxr-xr-x   2 root root 4096 2008-07-29 17:49 sessions
drwxr-xr-x   8 root root 4096 2008-07-29 17:58 themes

I just tried download and installed a random theme, it is then listed in
/usr/share/kde4/apps/kdm/themes but does not show up the Login Manager window so
it can be selected for install/use

Comment 6 Kevin Kofler 2008-08-01 00:05:21 UTC
What's the output of "kde4-config --path data"?

Comment 7 Colin J Thomson 2008-08-01 00:06:05 UTC
[g6avk@localhost themes]$ kde4-config --path data
/home/g6avk/.kde/share/apps/:/usr/share/kde4/apps/:/usr/share/kde-settings/kde-

Comment 8 Colin J Thomson 2008-08-01 00:09:34 UTC
Sorry a bit got cut off:

[g6avk@localhost themes]$ kde4-config --path data
/home/g6avk/.kde/share/apps/:/usr/share/kde4/apps/:/usr/share/kde-settings/kde-


Comment 9 Kevin Kofler 2008-08-01 00:11:49 UTC
It's still truncated.

Comment 10 Colin J Thomson 2008-08-01 00:13:57 UTC
Last try, sorry its late here:-

home/g6avk/.kde/share/apps/:
/usr/share/kde4/apps/:
/usr/share/kde-settings/kde-profile/default/share/apps/:
/usr/share/apps/


Comment 11 Kevin Kofler 2008-08-01 00:16:23 UTC
Hmmm, OK, then something is not working, normally /usr/share/kde4/apps should 
be listed again last.

Comment 12 Kevin Kofler 2008-08-01 00:18:41 UTC
OK, I see why it isn't working.

Comment 13 Colin J Thomson 2008-08-01 00:20:17 UTC
OK, I can confirm /usr/share/kde4/apps is only listed once as above.

Comment 14 Kevin Kofler 2008-08-01 00:48:02 UTC
Reassigning again kdelibs -> kdebase-workspace, as I now think the real fix 
will have to be in kdebase-workspace. The kstandarddirs paths are supposed to 
be unique, I don't think my hack (listing /usr/share/kde4/apps twice, which was 
what my change to the kstandarddirs patch was intended to do, but actually 
didn't) would have been a good idea anyway.

I'm working on a fix in kdebase-workspace.

Comment 15 Kevin Kofler 2008-08-01 00:57:19 UTC
Building kdebase-workspace-4.1.0-4 now, which should fix this.

Comment 16 Kevin Kofler 2008-08-01 02:01:05 UTC
Should be fixed in: http://koji.fedoraproject.org/koji/taskinfo?taskID=751515

(Note: "kde4-config --path data" will still return the same thing, but the KDM 
configuration should work.)

Comment 17 Rex Dieter 2008-08-01 14:28:00 UTC
seems to be a dup of bug #453321

Comment 18 Colin J Thomson 2008-08-01 19:14:40 UTC
OK, just updated to kdebase-workspace-* 4.1.0-4.fc9 and the other updates from
kde-redhat. 
The errors messages have now gone when starting the Login manger. Themes
download are listed in: 
/usr/share/kde4/apps/kdm/themes/

The problem now is they do not show in the Login managers window for selection.
I'll do some more digging around as I am not sure if there are different KDM
themes for kde3.x or kde4.x. Of course this could be a different bug also.


Comment 19 Kevin Kofler 2008-08-01 19:50:56 UTC
Rex is right, this is a duplicate of bug 453321.

Themes for the KDE 3 KDM do not work in the KDE 4 version.

*** This bug has been marked as a duplicate of 453321 ***

Comment 20 Fedora Update System 2008-09-10 07:18:49 UTC
kdeedu-4.1.0-1.fc9, quarticurve-kwin-theme-0.0-0.5.beta4.fc9, kdeartwork-4.1.0-1.fc9, kdetoys-4.1.0-1.fc9, kdesdk-4.1.0-1.fc9, PyQt4-4.4.2-2.fc9, kde-i18n-3.5.9-8.fc9, kdebase-4.1.0-1.fc9.1, sip-4.7.6-1.fc9, kdebase-workspace-4.1.0-8.fc9, automoc-1.0-0.8.rc1.fc9, kdegames-4.1.0-2.fc9, akonadi-1.0.0-2.fc9, soprano-2.1-1.fc9, konq-plugins-4.1.0-2.fc9, compiz-0.7.6-3.fc9.1, qt-4.4.1-2.fc9, qscintilla-2.2-3.fc9, kdepimlibs-4.1.0-2.fc9, kdebindings-4.1.0-5.fc9, kdenetwork-4.1.0-2.fc9, kde-l10n-4.1.0-2.fc9, kdeplasma-addons-4.1.0-1.fc9, qgtkstyle-0.0-0.2.20080719svn693.fc9, kdeutils-4.1.0-1.fc9.1, kdemultimedia-4.1.0-1.fc9, kdeadmin-4.1.0-2.fc9, kde-filesystem-4-17.fc9, kdeaccessibility-4.1.0-1.fc9, kdebase-runtime-4.1.0-3.fc9, phonon-4.2.0-4.fc9, kdegraphics-4.1.0-5.fc9, kdelibs-4.1.0-7.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.