Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455587 - NetworkManager dependencies set wrong
Summary: NetworkManager dependencies set wrong
Keywords:
Status: CLOSED DUPLICATE of bug 451519
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-16 13:26 UTC by Michael de Mare
Modified: 2008-07-18 17:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-18 17:42:13 UTC


Attachments (Terms of Use)

Description Michael de Mare 2008-07-16 13:26:31 UTC
Description of problem:

When I try to update my system, I get errors on NetworkManager.

Version-Release number of selected component (if applicable):

1:0.7.0-0.6.9.svn3675.fc8

How reproducible:

Reproduces

Steps to Reproduce:
1. sudo yum -y update
2.
3.
  
Actual results:

[mikey@r-mdemare ~]$ sudo yum -y update
Password:
livna                     100% |=========================| 2.1 kB    00:00
fedora                    100% |=========================| 2.1 kB    00:00
updates                   100% |=========================| 2.3 kB    00:00
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package iptables-ipv6.x86_64 0:1.4.1.1-1.fc8 set to be updated
---> Package java-1.7.0-icedtea.x86_64 0:1.7.0.0-0.20.b21.snapshot.fc8 set to 
be updated
---> Package docbook-dtds.noarch 0:1.0-33.fc8 set to be updated
---> Package texinfo-tex.x86_64 0:4.11-5.fc8 set to be updated
---> Package pdfedit.x86_64 0:0.4.1-1.fc8 set to be updated
---> Package kernel.x86_64 0:2.6.25.10-47.fc8 set to be installed
--> Processing Dependency: NetworkManager-glib = 1:0.7.0-0.6.7.svn3370.fc8 for 
package: NetworkManager
---> Package kmod-fglrx.x86_64 0:8.501-4.8.06.lvn8 set to be updated
--> Processing Dependency: kmod-fglrx-2.6.25.10-47.fc8 = 8.501-4.8.06.lvn8 for 
package: kmod-fglrx
---> Package kernel-devel.x86_64 0:2.6.25.10-47.fc8 set to be installed
---> Package hal-info.noarch 0:20080607-2.fc8 set to be updated
---> Package java-1.7.0-icedtea-src.x86_64 0:1.7.0.0-0.20.b21.snapshot.fc8 set 
to be updated
---> Package ntfs-3g.x86_64 2:1.2712-1.fc8 set to be updated
---> Package hal-devel.x86_64 0:0.5.10-3.fc8 set to be updated
---> Package info.x86_64 0:4.11-5.fc8 set to be updated
---> Package bind-utils.x86_64 32:9.5.0-28.P1.fc8 set to be updated
---> Package NetworkManager.x86_64 1:0.7.0-0.6.9.svn3675.fc8 set to be updated
---> Package NetworkManager-glib.x86_64 1:0.7.0-0.6.9.svn3675.fc8 set to be 
updated
---> Package texinfo.x86_64 0:4.11-5.fc8 set to be updated
--> Processing Dependency: liblirc_client.so.0()(64bit) for package: mplayer
--> Processing Dependency: liblirc_client.so.0()(64bit) for package: 
audacious-plugins
--> Processing Dependency: liblirc_client.so.0()(64bit) for package: mencoder
--> Processing Dependency: liblirc_client.so.0()(64bit) for package: lirc
--> Processing Dependency: liblirc_client.so.0()(64bit) for package: xine
---> Package bind-libs.x86_64 32:9.5.0-28.P1.fc8 set to be updated
---> Package NetworkManager-glib.i386 1:0.7.0-0.6.9.svn3675.fc8 set to be 
updated
---> Package hal-libs.x86_64 0:0.5.10-3.fc8 set to be updated
---> Package java-1.7.0-icedtea-devel.x86_64 0:1.7.0.0-0.20.b21.snapshot.fc8 
set to be updated
---> Package java-1.7.0-icedtea-demo.x86_64 0:1.7.0.0-0.20.b21.snapshot.fc8 
set to be updated
---> Package java-1.7.0-icedtea-javadoc.x86_64 0:1.7.0.0-0.20.b21.snapshot.fc8 
set to be updated
---> Package iptables.x86_64 0:1.4.1.1-1.fc8 set to be updated
---> Package NetworkManager-vpnc.x86_64 1:0.7.0-0.7.7.svn3627.fc8 set to be 
updated
---> Package kernel-headers.x86_64 0:2.6.25.10-47.fc8 set to be updated
---> Package java-1.7.0-icedtea-plugin.x86_64 0:1.7.0.0-0.20.b21.snapshot.fc8 
set to be updated
---> Package lirc.x86_64 0:0.8.3-1.fc8 set to be updated
---> Package hal.x86_64 0:0.5.10-3.fc8 set to be updated
---> Package ntfs-3g.i386 2:1.2712-1.fc8 set to be updated
---> Package hal-devel.i386 0:0.5.10-3.fc8 set to be updated
---> Package hal-libs.i386 0:0.5.10-3.fc8 set to be updated
---> Package fluidsynth-libs.x86_64 0:1.0.8-1.fc8 set to be updated
---> Package NetworkManager-gnome.x86_64 1:0.7.0-0.6.9.svn3675.fc8 set to be 
updated
---> Package NetworkManager-openvpn.x86_64 1:0.7.0-10.svn3632.fc8 set to be 
updated
--> Running transaction check
---> Package lirc-libs.x86_64 0:0.8.3-1.fc8 set to be updated
---> Package kmod-fglrx-2.6.25.10-47.fc8.x86_64 0:8.501-4.8.06.lvn8 set to be 
updated
--> Processing Conflict: NetworkManager conflicts NetworkManager-vpnc < 
1:0.7.0-0.7.7.svn3549
--> Processing Conflict: NetworkManager conflicts NetworkManager-openvpn < 
1:0.7.0-9.svn3549
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
--> Finished Dependency Resolution
--> Running transaction check
---> Package iptables-ipv6.x86_64 0:1.4.1.1-1.fc8 set to be updated
---> Package java-1.7.0-icedtea.x86_64 0:1.7.0.0-0.20.b21.snapshot.fc8 set to 
be updated
---> Package docbook-dtds.noarch 0:1.0-33.fc8 set to be updated
---> Package texinfo-tex.x86_64 0:4.11-5.fc8 set to be updated
---> Package pdfedit.x86_64 0:0.4.1-1.fc8 set to be updated
---> Package kernel.x86_64 0:2.6.25.10-47.fc8 set to be installed
---> Package kmod-fglrx.x86_64 0:8.501-4.8.06.lvn8 set to be updated
---> Package kernel-devel.x86_64 0:2.6.25.10-47.fc8 set to be installed
---> Package hal-info.noarch 0:20080607-2.fc8 set to be updated
---> Package java-1.7.0-icedtea-src.x86_64 0:1.7.0.0-0.20.b21.snapshot.fc8 set 
to be updated
---> Package ntfs-3g.x86_64 2:1.2712-1.fc8 set to be updated
---> Package kernel-devel.x86_64 0:2.6.25.6-27.fc8 set to be erased
---> Package lirc-libs.x86_64 0:0.8.3-1.fc8 set to be updated
---> Package hal-devel.x86_64 0:0.5.10-3.fc8 set to be updated
---> Package info.x86_64 0:4.11-5.fc8 set to be updated
---> Package bind-utils.x86_64 32:9.5.0-28.P1.fc8 set to be updated
---> Package NetworkManager.x86_64 1:0.7.0-0.6.9.svn3675.fc8 set to be updated
---> Package NetworkManager-glib.x86_64 1:0.7.0-0.6.9.svn3675.fc8 set to be 
updated
---> Package texinfo.x86_64 0:4.11-5.fc8 set to be updated
---> Package kernel.x86_64 0:2.6.25.6-27.fc8 set to be erased
--> Processing Dependency: kernel-x86_64 = 2.6.25.6-27.fc8 for package: 
kmod-fglrx-2.6.25.6-27.fc8
---> Package bind-libs.x86_64 32:9.5.0-28.P1.fc8 set to be updated
---> Package NetworkManager-glib.i386 1:0.7.0-0.6.9.svn3675.fc8 set to be 
updated
---> Package hal-libs.x86_64 0:0.5.10-3.fc8 set to be updated
---> Package java-1.7.0-icedtea-devel.x86_64 0:1.7.0.0-0.20.b21.snapshot.fc8 
set to be updated
---> Package java-1.7.0-icedtea-demo.x86_64 0:1.7.0.0-0.20.b21.snapshot.fc8 
set to be updated
---> Package java-1.7.0-icedtea-javadoc.x86_64 0:1.7.0.0-0.20.b21.snapshot.fc8 
set to be updated
---> Package iptables.x86_64 0:1.4.1.1-1.fc8 set to be updated
---> Package NetworkManager-vpnc.x86_64 1:0.7.0-0.7.7.svn3627.fc8 set to be 
updated
---> Package kernel-headers.x86_64 0:2.6.25.10-47.fc8 set to be updated
---> Package java-1.7.0-icedtea-plugin.x86_64 0:1.7.0.0-0.20.b21.snapshot.fc8 
set to be updated
---> Package lirc.x86_64 0:0.8.3-1.fc8 set to be updated
---> Package kmod-fglrx-2.6.25.10-47.fc8.x86_64 0:8.501-4.8.06.lvn8 set to be 
updated
---> Package hal.x86_64 0:0.5.10-3.fc8 set to be updated
---> Package ntfs-3g.i386 2:1.2712-1.fc8 set to be updated
---> Package hal-devel.i386 0:0.5.10-3.fc8 set to be updated
---> Package hal-libs.i386 0:0.5.10-3.fc8 set to be updated
---> Package fluidsynth-libs.x86_64 0:1.0.8-1.fc8 set to be updated
---> Package NetworkManager-gnome.x86_64 1:0.7.0-0.6.9.svn3675.fc8 set to be 
updated
---> Package NetworkManager-openvpn.x86_64 1:0.7.0-10.svn3632.fc8 set to be 
updated
--> Running transaction check
---> Package kmod-fglrx-2.6.25.6-27.fc8.x86_64 0:8.501-2.8.06.lvn8 set to be 
erased
--> Processing Conflict: NetworkManager conflicts NetworkManager-vpnc < 
1:0.7.0-0.7.7.svn3549
--> Processing Conflict: NetworkManager conflicts NetworkManager-openvpn < 
1:0.7.0-9.svn3549
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 kernel-devel            x86_64     2.6.25.10-47.fc8  updates           5.2 M
Updating:
 NetworkManager          x86_64     1:0.7.0-0.6.9.svn3675.fc8  updates           
787 k
 NetworkManager-glib     x86_64     1:0.7.0-0.6.9.svn3675.fc8  updates           
131 k
 NetworkManager-glib     i386       1:0.7.0-0.6.9.svn3675.fc8  updates           
130 k
 NetworkManager-gnome    x86_64     1:0.7.0-0.6.9.svn3675.fc8  updates           
336 k
 NetworkManager-openvpn  x86_64     1:0.7.0-10.svn3632.fc8  updates           
136 k
 NetworkManager-vpnc     x86_64     1:0.7.0-0.7.7.svn3627.fc8  updates           
110 k
 bind-libs               x86_64     32:9.5.0-28.P1.fc8  updates           985 
k
 bind-utils              x86_64     32:9.5.0-28.P1.fc8  updates           194 
k
 docbook-dtds            noarch     1.0-33.fc8       updates           813 k
 fluidsynth-libs         x86_64     1.0.8-1.fc8      updates           484 k
 hal                     x86_64     0.5.10-3.fc8     updates           468 k
 hal-devel               x86_64     0.5.10-3.fc8     updates            30 k
 hal-devel               i386       0.5.10-3.fc8     updates            30 k
 hal-info                noarch     20080607-2.fc8   updates           118 k
 hal-libs                x86_64     0.5.10-3.fc8     updates            63 k
 hal-libs                i386       0.5.10-3.fc8     updates            61 k
 info                    x86_64     4.11-5.fc8       updates           172 k
 iptables                x86_64     1.4.1.1-1.fc8    updates           345 k
 iptables-ipv6           x86_64     1.4.1.1-1.fc8    updates           208 k
 java-1.7.0-icedtea      x86_64     1.7.0.0-0.20.b21.snapshot.fc8  updates            
28 M
 java-1.7.0-icedtea-demo  x86_64     1.7.0.0-0.20.b21.snapshot.fc8  updates           
2.3 M
 java-1.7.0-icedtea-devel  x86_64     1.7.0.0-0.20.b21.snapshot.fc8  updates           
8.7 M
 java-1.7.0-icedtea-javadoc  x86_64     1.7.0.0-0.20.b21.snapshot.fc8  updates            
20 M
 java-1.7.0-icedtea-plugin  x86_64     1.7.0.0-0.20.b21.snapshot.fc8  updates            
21 k
 java-1.7.0-icedtea-src  x86_64     1.7.0.0-0.20.b21.snapshot.fc8  updates            
19 M
 kernel-headers          x86_64     2.6.25.10-47.fc8  updates           737 k
 kmod-fglrx              x86_64     8.501-4.8.06.lvn8  livna              19 k
 lirc                    x86_64     0.8.3-1.fc8      updates           262 k
 ntfs-3g                 x86_64     2:1.2712-1.fc8   updates           179 k
 ntfs-3g                 i386       2:1.2712-1.fc8   updates           192 k
 pdfedit                 x86_64     0.4.1-1.fc8      updates           2.7 M
 texinfo                 x86_64     4.11-5.fc8       updates           833 k
 texinfo-tex             x86_64     4.11-5.fc8       updates            42 k
Removing:
 kernel                  x86_64     2.6.25.6-27.fc8  installed          69 M
 kernel-devel            x86_64     2.6.25.6-27.fc8  installed          33 M
Installing for dependencies:
 kernel                  x86_64     2.6.25.10-47.fc8  updates            18 M
 kmod-fglrx-2.6.25.10-47.fc8  x86_64     8.501-4.8.06.lvn8  livna             
665 k
 lirc-libs               x86_64     0.8.3-1.fc8      updates            19 k
Removing for dependencies:
 kmod-fglrx-2.6.25.6-27.fc8  x86_64     8.501-2.8.06.lvn8  installed         
2.8 M

Transaction Summary
=============================================================================
Install      4 Package(s)
Update      33 Package(s)
Remove       3 Package(s)

Total download size: 112 M
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package NetworkManager conflicts with NetworkManager-vpnc < 
1:0.7.0-0.7.7.svn3549.
Package NetworkManager conflicts with NetworkManager-openvpn < 
1:0.7.0-9.svn3549.
Package NetworkManager needs NetworkManager-glib = 1:0.7.0-0.6.7.svn3370.fc8, 
this is not available.
Package NetworkManager needs NetworkManager-glib = 1:0.7.0-0.6.7.svn3370.fc8, 
this is not available.
Complete!
[mikey@r-mdemare ~]$          

Expected results:

system should patch

Additional info:

Comment 1 Michael de Mare 2008-07-18 12:52:40 UTC
I still can't update.  I think that you just need to replace the = with => in 
the condition for that library.


Comment 2 Dan Williams 2008-07-18 17:42:13 UTC

*** This bug has been marked as a duplicate of 451519 ***


Note You need to log in before you can comment on or make changes to this bug.