Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455584 - SELinux prevents xdm working correctly
Summary: SELinux prevents xdm working correctly
Keywords:
Status: CLOSED DUPLICATE of bug 388431
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-xdm
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-16 13:10 UTC by Adam Tkac
Modified: 2018-04-11 10:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-17 12:03:43 UTC


Attachments (Terms of Use)
AVC denials (deleted)
2008-07-16 13:22 UTC, Adam Tkac
no flags Details

Description Adam Tkac 2008-07-16 13:10:24 UTC
Description of problem:
I decided to start using SELinux on my laptop but it prevents execution of my
favourite destop

Version-Release number of selected component (if applicable):
# rpm -qa |grep selinux-policy
selinux-policy-3.3.1-78.fc9.noarch
selinux-policy-targeted-3.3.1-78.fc9.noarch

How reproducible:
always

Steps to Reproduce:
# cat /etc/sysconfig/desktop 
DISPLAYMANAGER=XDM
PREFERRED=/usr/bin/startfluxbox

and then try log into your desktop
  
Actual results:
fails due missing TE rules

Expected results:
successful login

Additional info:
I will attach commented file with AVC denials

Comment 1 Adam Tkac 2008-07-16 13:22:53 UTC
Created attachment 311949 [details]
AVC denials

Comment 2 Daniel Walsh 2008-07-16 13:48:20 UTC
/etc/X11/xdm/authdir/authfiles directory should be writable (file "A:0-EQRIz0"
is created in this case)

I have no idea what these files are, none of these files/directrories exist when
I install fluxbox?  They are in a horrible location.  Variable files should be
in /var/run/fluxbox?  /var/lib/fluxbox?

If this is authorization data, you could choose:

/var/lib/abl(/.*)?	system_u:object_r:var_auth_t:s0
/var/run/xauth(/.*)?	system_u:object_r:xdm_var_run_t:s0
/var/lib/pam_ssh(/.*)?	system_u:object_r:var_auth_t:s0
/var/run/pam_ssh(/.*)?	system_u:object_r:var_auth_t:s0
/var/run/saslauthd(/.*)?	system_u:object_r:saslauthd_var_run_t:s0
/var/cache/coolkey(/.*)?	system_u:object_r:auth_cache_t:s0

Or create a new one.

/var/log/[kw]dm\.log.*	--	system_u:object_r:xserver_log_t:s0
/var/log/gdm(/.*)?	system_u:object_r:xserver_log_t:s0
/var/log/Xorg.*	--	system_u:object_r:xserver_log_t:s0
/var/log/XFree86.*	--	system_u:object_r:xserver_log_t:s0
/var/log/nvidia-installer\.log.*	--	system_u:object_r:xserver_log_t:s0

xserver log should match one of these I would think?  /var/log/Xorg.0.log seems
to be the way gdm does it.

What pam module does fluxbox use?  Does it include pam_selinux?


Comment 3 Adam Tkac 2008-07-17 11:52:55 UTC
Moving to proper component

Comment 4 Matěj Cepl 2008-07-17 12:03:43 UTC

*** This bug has been marked as a duplicate of 388431 ***


Note You need to log in before you can comment on or make changes to this bug.