Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455579 - Suspend to RAM will corrupt memory on x86_64 systems with >4GB of RAM
Summary: Suspend to RAM will corrupt memory on x86_64 systems with >4GB of RAM
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.3
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: John Feeney
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks: 455409
TreeView+ depends on / blocked
 
Reported: 2008-07-16 11:50 UTC by Matthew Garrett
Modified: 2013-01-10 07:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-12 18:16:42 UTC


Attachments (Terms of Use)
Backported patch from 2.6.26 (deleted)
2008-07-16 11:50 UTC, Matthew Garrett
no flags Details | Diff

Description Matthew Garrett 2008-07-16 11:50:13 UTC
The PCI GART code has no suspend/resume support. As a consequence, on resume the
GART may be pointing to an incorrect location and significant memory corruption
may occur. The workaround in 2.6.26 is to add stub functions which simply reject
a suspend in this case. This patch is a backport from 2.6.26 to RHEL.

Comment 1 Matthew Garrett 2008-07-16 11:50:13 UTC
Created attachment 311943 [details]
Backported patch from 2.6.26

Comment 2 Matthew Garrett 2008-08-12 18:16:42 UTC

*** This bug has been marked as a duplicate of bug 452961 ***


Note You need to log in before you can comment on or make changes to this bug.