Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455569 - [PATCH] Fixing NETWORKING_IPV6=no
Summary: [PATCH] Fixing NETWORKING_IPV6=no
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 9
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-16 10:32 UTC by Andreas Thienemann
Modified: 2014-03-17 03:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-16 17:33:33 UTC


Attachments (Terms of Use)
Re-enable NETWORKING_IPV6 toggle (deleted)
2008-07-16 10:32 UTC, Andreas Thienemann
no flags Details | Diff

Description Andreas Thienemann 2008-07-16 10:32:47 UTC
In the recent past a change to the ipv6 init code has made the NETWORKING_IPV6
toggle in /etc/sysconfig/network useless. Before this change, the toggle could
be used to disable IPV6 support on a box.

Since this change, the function ipv6_test() which should test for ipv6
functionality inserts the ipv6 module by calling modprobe.

This one-line patch adds a conditional check for the NETWORKING_IPV6 parameter
to the ipv6 initscript and bails if set to no.

That way, if the system administrator configured the system to not use IPV6, no
ipv6 addresses (not even fe80:: ones) are initialized and the NETWORKING_IPV6
parameter is useful again.

Comment 1 Andreas Thienemann 2008-07-16 10:32:47 UTC
Created attachment 311938 [details]
Re-enable NETWORKING_IPV6 toggle

Comment 2 Bill Nottingham 2008-07-16 17:33:33 UTC
Won't help, as it can be autoloaded by the usage of various system calls that
open a socket.

If you want to disable IPv6, the only way to do it is:

  install ipv6 /bin/true

in /etc/modprobe.conf, or a modprobe.d file.

Comment 3 Andreas Thienemann 2008-07-17 09:59:28 UTC
Nope, the correct way of preventing autoloading is an entry alias net-pf-10 off
on modprobe.conf.

This however depends on the documented NETWORKING_IPV6 parameter which suddenly
stopped working.

So I'd ask you to please reconsider your WONTFIX tag as this patch fixes said
regression.


Note You need to log in before you can comment on or make changes to this bug.