Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455564 - named init script doesn't wait for server terminaton
Summary: named init script doesn't wait for server terminaton
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: bind
Version: 5.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Adam Tkac
QA Contact:
URL:
Whiteboard:
Depends On: 455540
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-16 08:53 UTC by Adam Tkac
Modified: 2013-04-30 23:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-14 10:00:22 UTC


Attachments (Terms of Use)

Description Adam Tkac 2008-07-16 08:53:28 UTC
+++ This bug was initially created as a clone of Bug #455540 +++

Description of problem:

It looks like this is was likely addressed in bug 426382, however there is no
fix incorporated into RH 4 (and presumably 5, though I have not verified). If
named is stopped via rndc, it won't exit immediately and as such the 'start' of
a 'restart' will be attempted before the prior instance had completed shutdown.

Version-Release number of selected component (if applicable):

bind-9.2.4-28.0.1.el4

How reproducible:

Get a reasonably loaded bind instance going (~200mb of heap in this case) and
execute a restart via the stock init script. Most of the time the start will
fail due to the daemon still exiting.

A fix as trivial as:

128a129,131
>               while pidofproc named >/dev/null 2>&1; do
>                       sleep 1
>               done
158,159d160
< # wait a couple of seconds for the named to finish closing down
<       sleep 2

...resolves the issue.

-- Additional comment from atkac@redhat.com on 2008-07-16 04:52 EST --
Right you are. Thanks for your report

Comment 2 Adam Tkac 2008-08-14 10:00:22 UTC
Hm, after inspection this bug affects only RHEL4 systems. RHEL5 initscript is already sane. Closing


Note You need to log in before you can comment on or make changes to this bug.