Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455499 - Seamonkey 1.1.10 crashes in gtk2 dialog
Summary: Seamonkey 1.1.10 crashes in gtk2 dialog
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gtk2
Version: 5.2
Hardware: i386
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Benjamin Otte
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-15 19:00 UTC by Greg Bailey
Modified: 2014-06-09 13:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:07:20 UTC


Attachments (Terms of Use)

Description Greg Bailey 2008-07-15 19:00:13 UTC
+++ This bug was initially created as a clone of Bug #437132 +++

My problem sounds very similar to Bug #437132, except that I am running
Seamonkey 1.1.10 on CentOS 5.2 instead of firefox.  I'm not sure of the steps to
reproduce this problem as the crashes are intermittent.  However, when the
crashes occur, I see the following on the xterm from which I invoked seamonkey:

(Gecko:22468): Gdk-CRITICAL **: gdk_colormap_get_screen: assertion
`GDK_IS_COLORMAP (cmap)' failed

(Gecko:22468): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT
(object)' failed

(Gecko:22468): Gdk-CRITICAL **: gdk_colormap_get_visual: assertion
`GDK_IS_COLORMAP (colormap)' failed
/usr/lib/seamonkey-1.1.10/run-mozilla.sh: line 131: 22468 Segmentation fault   
  "$prog" ${1+"$@"}

[1]+  Exit 139                mozilla

This output matches exactly the symptoms reported at:

http://www.centos.org/modules/newbb/viewtopic.php?topic_id=11589&viewmode=flat&order=ASC&start=20

at comment #23.

In my environment, "mozilla" is a symlink to "seamonkey".

The comments indicated in Bug #437132 indicate that the GTK+ problem should
hopefully be fixed by RHEL-5.2, but in querying the changelog for gtk2, I don't
see any evidence of recent patches to address this.

Relevant comments from the original bug #437132 are below:

Firefox crashes when it tries to open a new GTK dialog. The crash is inside GTK.

-- Additional comment from j.s.peatfield@damtp.cam.ac.uk on 2008-04-11 16:25 EST --
That is certainly *a* bug in GTK with a fix available - which should obviously
be fixed in GTK.

Since the discussion in there seems to be related to problems with re-parenting
an object when it is dragged in a notebook it isn't entirely obvious that this
is the bug which is causing ffox (and tbird etc) to crash - or at least not
obviously the *only* bug...

-- Additional comment from stransky@redhat.com on 2008-05-29 09:32 EST --
Hopefully fixed by the RHEL-5.2 update. Please reopen if not.

Comment 3 RHEL Product and Program Management 2014-03-07 13:39:00 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 4 RHEL Product and Program Management 2014-06-02 13:07:20 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Comment 5 Greg Bailey 2014-06-09 13:01:14 UTC
Just received a reminder email from bugzilla to update my requests that have needinfo set in them.  Clearing this as I have not had the equipment to reproduce this for a long time, and was closed WONTFIX anyway.


Note You need to log in before you can comment on or make changes to this bug.