Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455467 - gtk2 slowness while rendering widgets in rawhide
Summary: gtk2 slowness while rendering widgets in rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk2
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-15 17:11 UTC by Stewart Adam
Modified: 2008-09-05 03:15 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-05 03:15:40 UTC


Attachments (Terms of Use)

Description Stewart Adam 2008-07-15 17:11:08 UTC
Description of problem:
I'm not sure how to explain it, but the gtk2 in rawhide is much, much slower
than the one in Fedora 9. Ever since the upgrade to gtk2-2.13.4-2.fc10.x86_64,
every application which uses gtk2 seems to take forever to render and CPU
utilization seems to be much higher.

Version-Release number of selected component (if applicable):
gtk2-2.13.4-2.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Load up Evolution with lots of messages
2. Load up a directory in Nautilus with >=500 files
3. etc
  
Actual results:
CPU utilization is high for longer periods of time as widget rendering takes place

Expected results:
It was as fast as in F-9

Additional info:
This was also present in the F9 tests/alphas/betas - I'm sorry if this is the
intentional behaviour (as in the slowness is caused by extra debugging code or
something similar which is enabled for rawhide only).

Comment 1 Matthias Clasen 2008-09-05 03:15:40 UTC
It looks like gtk2 was build with -O0 for a while. The latest build should be back to regular CFLAGS, let me know if that doesn't help.


Note You need to log in before you can comment on or make changes to this bug.