Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455440 - perl-IPC-ShareLite won't upgrade during 510 -> 520 upgrade
Summary: perl-IPC-ShareLite won't upgrade during 510 -> 520 upgrade
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer
Version: 520
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Milan Zázrivec
QA Contact: Steve Salevan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-15 14:55 UTC by Milan Zázrivec
Modified: 2008-11-05 18:41 UTC (History)
0 users

Fixed In Version: sat520
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-05 18:41:13 UTC


Attachments (Terms of Use)
This is what happens, when upgrading perl-IPC-ShareLite manually (deleted)
2008-07-15 14:56 UTC, Milan Zázrivec
no flags Details

Description Milan Zázrivec 2008-07-15 14:55:09 UTC
Description of problem:
When running sat510 -> sat520 upgrade on a s390x system, upgrade process
fails when trying to upgrade perl-IPC-ShareLite package. The upgrade failure
is caused by the fact, that for some reason sat510 s390x iso contains s390
(i.e. 31-bit) version of the mentioned package.

Version-Release number of selected component (if applicable):
satellite 5.2.0 / perl-IPC-ShareLite-0.13-1.el4.s390x

How reproducible:
Always

Steps to Reproduce:
1. Install Satellite 5.1.0 on a s390x machine
2. Run 5.1.0 -> 5.2.0 upgrade
  
Actual results:
See attachment.

Expected results:
Upgrade process completes smoothly and without package upgrade errors.

Comment 1 Milan Zázrivec 2008-07-15 14:56:24 UTC
Created attachment 311842 [details]
This is what happens, when upgrading perl-IPC-ShareLite manually

Comment 2 Milan Zázrivec 2008-07-17 15:25:04 UTC
As long as the perl-IPC-ShareLite.s390x package contains ShareLite.so library,
the upgrade from older version of perl-IPC-ShareLite.s390 to the latest version
of perl-IPC-ShareLite.s390x fails, complaining about conflicting manual page.

When the ShareLite.so library is not included in the package, the whole upgrade
proceeds smoothly, it does not complaing about conflicting files (man pages)
at all.

Nonetheless, the reason why this is happening is still unknown to me.

Comment 3 Milan Zázrivec 2008-07-21 10:29:23 UTC
During the package upgrade rpm decided not to include erasing of the older
version into the transaction, hence the file conflict. The reason why this
is happening is that during upgrade rpm erases only packages of the same
color (see rpm sources, lib/depends.c, rpmtsAddInstallElement() routine).

The real fix (or workaround) is then to either make the s390x version of
the package contain also a s390 version of ShareLite.so or turn out
file coloring during package build.

I decided to turn the file coloring off; these two lines in spec file should
take care of it:

%ifarch s390x s390
%define _use_internal_dependency_generator 0
%endif

Sending        perl-IPC-ShareLite/perl-IPC-ShareLite.spec
Transmitting file data .
Committed revision 175362.

Comment 4 Brad Buckingham 2008-08-13 16:54:49 UTC
Mass move to ON_QA.

Comment 5 Steve Salevan 2008-09-02 19:10:48 UTC
This package upgrades successfully with no errors during a RHEL4 s390x 511->520 upgrade.  Moving to VERIFIED.

Comment 6 Steve Salevan 2008-10-28 15:44:57 UTC
It upgrades successfully, registered to Stage and using RPMs and ISOs pushed to Stage.  Moving to RELEASE_PENDING.

Comment 7 Brandon Perkins 2008-11-05 18:41:13 UTC
5.2.0 Satellite is now GA, bugs Closed for Current Release.


Note You need to log in before you can comment on or make changes to this bug.