Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455420 - [5.2] Display Resolution won't be changed on 2nd time.('system-config-display' command doesn't work properly.)
Summary: [5.2] Display Resolution won't be changed on 2nd time.('system-config-display...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhpxl
Version: 5.2
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Milan Crha
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-15 13:43 UTC by Alan Matsuoka
Modified: 2018-10-19 21:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-14 08:47:17 UTC
Target Upstream Version:


Attachments (Terms of Use)
rhpxl-0.41.1.IT113236.patch (deleted)
2008-07-15 13:43 UTC, Alan Matsuoka
no flags Details | Diff
rhpxl-0.41.1-6.test0.i386.rpm (deleted)
2008-07-15 13:43 UTC, Alan Matsuoka
no flags Details
version_info.txt (deleted)
2008-07-15 13:44 UTC, Alan Matsuoka
no flags Details
Xorg.log.tar.gz (deleted)
2008-07-15 13:44 UTC, Alan Matsuoka
no flags Details
xorg.conf.tar.gz (deleted)
2008-07-15 13:44 UTC, Alan Matsuoka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0809 normal SHIPPED_LIVE rhpxl bug fix update 2008-08-14 08:47:14 UTC

Description Alan Matsuoka 2008-07-15 13:43:18 UTC
ustomer Name:
 Fujitsu


Red Hat Customer ID# or RHN System ID:


Customer Contact Name:
 Katsu Fukazawa

Summary:
 Display Resolution won't be changed on 2nd time.
 ("system-config-display" command doesn't work properly.)


Version-Release of Selected Component:
 Red Hat Enterprise Linux (v.5) for EM64T
 Kernel RC
 system-config-display-1.0.48-2.el5.noarch.rpm

Drivers or hardware dependency:


Description of Problem:
 Once we change the display resolution by using the
 "system-config-display"command, the value of xorg.conf
 hasn't been changed, even though "system-config-display"
 command was executed again.

How reproducible:
 always

Step to Reproduce:

** This environment is in Japanese language mode.
  The name of a tag and button may be different from English mode.

 1) Execution of the "system-config-display" command.

 2) Select "Hard ware" tag, then click on "Configure" button.
    Choose Generic "Monitor 1024x768", then click OK.

 3) Logout.  We could see that monitor resolution has been
    changed at this time.

 4) Execution of the "system-config-display" command again.

 5) Select "Hard ware" tag then click on "Configure" button.

 6) Choose Generic "Monitor 800x600", then click OK.

 7) After logout/login, Monitor resolution has not been changed
    to 800x600.

 8) We found out that value of "Section Monitor" (in the xorg.conf)
    was not same value with we set on step 7).


Actual Results:
 Display resolution won't be changed to what we want.


Expected Result:
 Display resolution can be changed.


Summary of actions taken to resolve issue:


Location of diagnostic data:
 N/A

Hardware configuration:


Software:


Additional Info:


Business Impact:
Many user want to change the monitor resolution.
But they can't.

Other:
We think that this problem need to be fixed before GA is released.
We would like you to confirm that x86 and/or IPF has same problem.

Please call me if you have any question.

SEG Notes:

test package supplied with the following notes:
Mr.Matsuya

We cannot prepare the machine using mga driver this time.
So, we have tested with machine using ati driver.
We could reproduce this issue on ati machine, so I attach a package information
(version_info.txt).

> First, my monitor type on hardware tab was \"LCD Panel 1024x768\", and the default
> resolution was 1024x768.
>
> I selected 800x600 as the resolution by system-config-display, and logout/login.
> The resolution was changed to 800x600. Then, I ran system-config-display again,
> and I confirmed that I could select 1024x768 as resolution. Finally, I could
> revert the resolution back to 1024x768.

I think we are looking at different point that may be because I could not tell
you \"Description of Problem\" and \"Step to Reproduce\" clearly.
Let me explain again.

> First, my monitor type on hardware tab was \"LCD Panel 1024x768\", and the default
> resolution was 1024x768.

If you choose \"LCD 800x600\" at first time of system-config-display, you are
not going to be able to change the monitor type in the \"Hard ware\" tab on 2nd
time.  (Please make sure we are having same issue...)
This is the point we are talking about.
We think the monitor type should be changed by using the \"Hard ware\" tab.


*** Step to Reproduce ***
1) Execution of the \"system-config-display\" command.

2) Select \"Hard ware\" tag, then click on \"Configure\" button of monitor type.
   Choose generic \"Monitor 800x600\", then click OK.

3) Logout

4) Login, and execute \"system-config-display\" command again.
   We could see that the monitor type has been changed \"Monitor 800x600\" at
this time.

5) Select \"Hard ware\" tag then click on \"Configure\" button of monitor type.
   Choose Generic \"Monitor 1024x768\", then click OK.

6) Logout

7) Login, and execute \"system-config-display\" command again.
   We could see that the monitor type has not been changed \"Monitor 1024x768\"
at this time (remain \"Monitor 800x600\").

8) We found out that value of \"Section Monitor\" (in the xorg.conf) was
\"Monitor 800x600\".


Regards,
Ryo Kimura

----------------------------------------
Hello Kikitsu-san,

I could reproduce this issue and investigated this issue. As the result, I found
that the indentified monitor type is not set in merge_into() of xhwstate.py in
rhpxl. And, I search the bugzilla and I found the same issue of fedora.

 https://bugzilla.redhat.com/show_bug.cgi?id=234131

I tested the patch in this bugzilla on EL5.2. And, I confirmed that this problem
was gone. I'll upload the test rhpxl package for your testing later.

I will report this result to SEG/ENG.
-----------------------------------------
This problem was not fixed by BZ289421. We need the new bugzilla for this issue.
Can you please create the new bugzilla? Please set "rhpxl" as the component of
the bugzilla.

This is the same issue as this bugzilla for fedora.
 https://bugzilla.redhat.com/show_bug.cgi?id=234131

Description of Problem:
 If the monitor type() is set in system-config-display once, the monitor type
can never be changed. The workaround is the manual change of /etc/X11/xorg.conf
or deleting /etc/X11/xorg.conf.

This is a bug in rhpxl package. So, this is not the hardware specific issue.
This can occur even with any graphic drivers.

I confirmed that this issue was fixed by the patch in BZ234131.
I'll upload the backported patch for EL5.2.

Comment 1 Alan Matsuoka 2008-07-15 13:43:19 UTC
Created attachment 311821 [details]
rhpxl-0.41.1.IT113236.patch

Comment 2 Alan Matsuoka 2008-07-15 13:43:51 UTC
Created attachment 311822 [details]
rhpxl-0.41.1-6.test0.i386.rpm

Comment 3 Alan Matsuoka 2008-07-15 13:44:17 UTC
Created attachment 311823 [details]
version_info.txt

Comment 4 Alan Matsuoka 2008-07-15 13:44:36 UTC
Created attachment 311824 [details]
Xorg.log.tar.gz

Comment 5 Alan Matsuoka 2008-07-15 13:44:53 UTC
Created attachment 311825 [details]
xorg.conf.tar.gz

Comment 17 errata-xmlrpc 2008-08-14 08:47:17 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0809.html


Note You need to log in before you can comment on or make changes to this bug.