Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455419 - REGRESSION: No wireless with b43 driver
Summary: REGRESSION: No wireless with b43 driver
Keywords:
Status: CLOSED DUPLICATE of bug 453390
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 9
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-15 13:38 UTC by Vegard Nossum
Modified: 2008-07-15 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-15 16:34:01 UTC


Attachments (Terms of Use)

Description Vegard Nossum 2008-07-15 13:38:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061712 Fedora/3.0-1.fc9 Firefox/3.0

Description of problem:
There is no wireless connection. I am using NetworkManager, and the network appears in the list, but when I choose my network, the icon just spins until eventually a box pops up asking me to re-type the keyring password or the WPA key.

This is a REGRESSION. Kernel version 2.6.25-14.fc9.i686 works every time. After updating the kernel to 2.6.25.9-76.fc9.i686, it stopped working. The vanilla -rc kernels for 2.6.26 have all worked perfectly (compiled by me).

The first relevant difference in the kernel log between the BAD and the GOOD version is this:

+wlan0: disassociate(reason=3)

I don't know what reason 3 is. include/linux/wireless.h has this:

#define IW_MLME_ASSOC           3

Is there a way to see all patches that have been added to Fedora kernels? Is it also possible to see a list of patches that were added/removed between those versions?

Version-Release number of selected component (if applicable):
kernel-2.6.25.9-76

How reproducible:
Always


Steps to Reproduce:
1. Start machine
2. Enter keyring password into nm-applet
3. Wait for nothing to happen

Actual Results:


Expected Results:


Additional info:
 b43-phy0: Broadcom 4311 WLAN found
 b43-phy0 debug: Found PHY: Analog 4, Type 2, Revision 8
 b43-phy0 debug: Found Radio: Manuf 0x17F, Version 0x2050, Revision 2

[...]

 b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
 b43-phy0 debug: Chip initialized
 b43-phy0 debug: 32-bit DMA initialized
 Registered led device: b43-phy0::tx
 Registered led device: b43-phy0::rx
 Registered led device: b43-phy0::radio
 b43-phy0 debug: Wireless interface started
 b43-phy0 debug: Adding Interface type 2
 ADDRCONF(NETDEV_UP): wlan0: link is not ready
 wlan0: Initial auth_alg=0
 wlan0: authenticate with AP 00:1c:f0:83:8e:26
 wlan0: RX authentication from 00:1c:f0:83:8e:26 (alg=0 transaction=2 status=0)
 wlan0: authenticated
 wlan0: associate with AP 00:1c:f0:83:8e:26
 wlan0: RX AssocResp from 00:1c:f0:83:8e:26 (capab=0x431 status=0 aid=2)
 wlan0: associated
 wlan0: switched to short barker preamble (BSSID=00:1c:f0:83:8e:26)
 ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
+wlan0: disassociate(reason=3)
 wlan0: no IPv6 routers present
+wlan0: Initial auth_alg=0
+wlan0: authenticate with AP 00:1c:f0:83:8e:26
+wlan0: Initial auth_alg=0
+wlan0: authenticate with AP 00:1c:f0:83:8e:26
+wlan0: RX authentication from 00:1c:f0:83:8e:26 (alg=0 transaction=2 status=0)
+wlan0: authenticated
+wlan0: associate with AP 00:1c:f0:83:8e:26
+wlan0: authentication frame received from 00:1c:f0:83:8e:26, but not in authent
+wlan0: RX ReassocResp from 00:1c:f0:83:8e:26 (capab=0x431 status=0 aid=2)
+wlan0: associated
+wlan0: switched to short barker preamble (BSSID=00:1c:f0:83:8e:26)
+wlan0: disassociate(reason=3)

[repeats]

Comment 1 John W. Linville 2008-07-15 16:34:01 UTC

*** This bug has been marked as a duplicate of 453390 ***


Note You need to log in before you can comment on or make changes to this bug.