Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455418 - Samba server can't authenticate to NT domain after 2008-05-28 update
Summary: Samba server can't authenticate to NT domain after 2008-05-28 update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: samba
Version: 5.2
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Simo Sorce
QA Contact:
URL:
Whiteboard:
Depends On: 449000
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-15 13:29 UTC by RHEL Product and Program Management
Modified: 2009-02-16 15:52 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
* when establishing connections with NETLOGON, Samba uses the Active Directory netlogon negotiate flags even outside of Active Directory environments. This avoids machines running Windows Server 2008 from incorrectly identifying the connection attempt as a downgrade attack. However, these same flags would prevent a successful connection with machines running Windows NT. Therefore, if attempts to make a connection fail while the Active Directory netlogon negotiate flags are set, Samba will try again without the flags in place so that successful connections with machines running Windows NT are possible.
Clone Of:
Environment:
Last Closed: 2009-02-16 15:52:31 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0251 normal SHIPPED_LIVE samba bug fix update 2009-02-16 15:52:24 UTC

Description RHEL Product and Program Management 2008-07-15 13:29:00 UTC
This bug has been copied from bug #449000 and has been proposed
to be backported to 5.2 z-stream (EUS).

Comment 3 RHEL Product and Program Management 2008-07-15 13:53:00 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being marked as a blocker for this release.  

Please resolve ASAP.

Comment 6 Ruediger Landmann 2009-01-27 22:35:22 UTC
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
* when establishing connections with NETLOGON, Samba uses the Active Directory netlogon negotiate flags even outside of Active Directory environments. This avoids machines running Windows Server 2008 from incorrectly identifying the connection attempt as a downgrade attack. However, these same flags would prevent a successful connection with machines running Windows NT. Therefore, if attempts to make a connection fail while the Active Directory netlogon negotiate flags are set, Samba will try again without the flags in place so that successful connections with machines running Windows NT are possible.

Comment 9 errata-xmlrpc 2009-02-16 15:52:31 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0251.html


Note You need to log in before you can comment on or make changes to this bug.