Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455417 - samba cannot join windows 2000 domains
Summary: samba cannot join windows 2000 domains
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: samba
Version: 5.2
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Simo Sorce
QA Contact:
URL:
Whiteboard:
Depends On: 450533
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-15 13:27 UTC by RHEL Product and Program Management
Modified: 2009-09-03 13:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
* when NT_STATUS is set to NT_STATUS_NOLOGON_WORKSTATION_TRUST_ACCOUNT, NT_STATUS_NOLOGON_SERVER_TRUST_ACCOUNT, or NT_STATUS_NOLOGON_INTERDOMAIN_TRUST_ACCOUNT, attempts to open an authenticated connection in a Windows 2000 Active Directory environment will fail automatically. Previously, Samba did not allow for this, and would attempt to open authenticated sessions in such environments. Now, when faced with any of these NT_STATUS conditions in an Active Directory environment, Samba will open an anonymous connection instead.
Clone Of:
Environment:
Last Closed: 2009-02-16 15:52:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0251 normal SHIPPED_LIVE samba bug fix update 2009-02-16 15:52:24 UTC

Description RHEL Product and Program Management 2008-07-15 13:27:29 UTC
This bug has been copied from bug #450533 and has been proposed
to be backported to 5.2 z-stream (EUS).

Comment 3 RHEL Product and Program Management 2008-07-15 13:53:04 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being marked as a blocker for this release.  

Please resolve ASAP.

Comment 7 Ruediger Landmann 2009-01-27 22:34:23 UTC
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
* when NT_STATUS is set to NT_STATUS_NOLOGON_WORKSTATION_TRUST_ACCOUNT, NT_STATUS_NOLOGON_SERVER_TRUST_ACCOUNT, or NT_STATUS_NOLOGON_INTERDOMAIN_TRUST_ACCOUNT, attempts to open an authenticated connection in a Windows 2000 Active Directory environment will fail automatically. Previously, Samba did not allow for this, and would attempt to open authenticated sessions in such environments. Now, when faced with any of these NT_STATUS conditions in an Active Directory environment, Samba will open an anonymous connection instead.

Comment 9 errata-xmlrpc 2009-02-16 15:52:28 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0251.html


Note You need to log in before you can comment on or make changes to this bug.