Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455413 - gtk-qt-engine prevents gvim from opening
Summary: gtk-qt-engine prevents gvim from opening
Keywords:
Status: CLOSED DUPLICATE of bug 501427
Alias: None
Product: Fedora
Classification: Fedora
Component: vim
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-15 13:21 UTC by Mary Ellen Foster
Modified: 2009-05-26 08:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-05-26 08:54:40 UTC


Attachments (Terms of Use)
Backtrace when I killed a hanging gvim (deleted)
2008-11-05 16:42 UTC, Mary Ellen Foster
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 270972 None None None Never

Description Mary Ellen Foster 2008-07-15 13:21:40 UTC
Description of problem:
While gtk-qt-engine was enabled, I wasn't able to open gvim; it would hang
without ever showing a window and had to be Ctrl-C'd. As soon as I removed
gtk-qt-engine (didn't try disabling it), gvim opened fine again.

Version-Release number of selected component (if applicable):
gtk-qt-engine-1.1-1.fc9

How reproducible:
Every time

Steps to Reproduce:
1. Type "gvim"
  
Actual results:
Hang until it's killed

Expected results:
My favourite retro text editor to open

Comment 1 Rex Dieter 2008-09-05 16:19:55 UTC
I can reproduce the failure.  Odds are it's an application bug (gtk-qt-engine is good at exposing stuff like that).  Reassigning to vim.

Comment 2 Mary Ellen Foster 2008-11-05 16:03:58 UTC
Seems to be an issue in Ubuntu too ...

Comment 3 Mary Ellen Foster 2008-11-05 16:06:35 UTC
Additional information gathered from the Ubuntu bug: running "gvim -X" (telling it not to connect to the X server) seems to work around the bug.

Comment 4 Mary Ellen Foster 2008-11-05 16:42:10 UTC
Created attachment 322606 [details]
Backtrace when I killed a hanging gvim

Here's the backtrace I got (missing some details, sorry) when I ran gvim under gtk-qt-engine, waited for it to hang, and then typed "bt".

Comment 5 Mary Ellen Foster 2008-11-28 15:16:34 UTC
Another workaround: explicitly specifying a GTK style in the chooser (e.g., "Bluecurve") instead of the default "Use my style" also seems to fix the issue.

Comment 6 Mary Ellen Foster 2009-04-17 08:37:35 UTC
Still an issue in Rawhide with
    gtk-qt-engine-1.1-5.fc11.i586
    vim-X11-7.2.148-1.fc11.i586

The same workaround -- choosing a specific style for GTK widgets rather than using the default -- still applies too.

Comment 7 Karsten Hopp 2009-05-26 08:54:40 UTC

*** This bug has been marked as a duplicate of bug 501427 ***


Note You need to log in before you can comment on or make changes to this bug.