Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455410 - Massive error messages and interrupting reverting of multiple local changes
Summary: Massive error messages and interrupting reverting of multiple local changes
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-SVK
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ian Burrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 480502
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-15 13:08 UTC by Frank Wittig
Modified: 2009-01-21 21:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-21 21:39:15 UTC


Attachments (Terms of Use)

Description Frank Wittig 2008-07-15 13:08:58 UTC
Description of problem:
When working with svk in Fedora 9 svk throws massive error messages that seem to
be mostly harmless. This is extremely annoying since it hides real issues the
user has to care about.

The messages are (repeated several dozen to hundred times):
- When updating checkout:
Name "swig_runtime_data::type_pointer3" used only once: possible typo at
/usr/lib/perl5/5.10.0/i386-linux-thread-multi/DynaLoader.pm line 226.
Attempt to free unreferenced scalar: SV 0x934d354, Perl interpreter: 0x88fb008
at /usr/lib/perl5/vendor_perl/5.10.0/SVK/XD.pm line 1371.

- When switching to a branch:
Attempt to free unreferenced scalar: SV 0xaecf30c, Perl interpreter: 0x9d3e008
at /usr/lib/perl5/vendor_perl/5.10.0/SVK/XD.pm line 856.
	(in cleanup) panic: free from wrong pool at
/usr/lib/perl5/vendor_perl/5.10.0/PerlIO/via/dynamic.pm line 167.
Attempt to free unreferenced scalar: SV 0xaebec84, Perl interpreter: 0x9d3e008
at /usr/lib/perl5/vendor_perl/5.10.0/SVK/Inspector/Root.pm line 82.


When reverting recursively the problem occurs that reverting fails leaving the
mirror locked. To completely revert its necessary to cleanup and revert several
times (again dozens to hundred - according to the number of affected files).

Error messages are the above mentioned plus:
- Last message when reverting fails:
Attempt to free unreferenced scalar: SV 0x8e03ef4, Perl interpreter: 0x81f4008
at /usr/lib/perl5/vendor_perl/5.10.0/SVK/XD.pm line 1371.

- When trying to revert again:
Name "swig_runtime_data::type_pointer3" used only once: possible typo at
/usr/lib/perl5/5.10.0/i386-linux-thread-multi/DynaLoader.pm line 226.
/automount/wwkdev/elias/wdp already locked, use 'svk cleanup' if lock is stalled

- Cleanup (looks ok besides the "usual" message):
Name "swig_runtime_data::type_pointer3" used only once: possible typo at
/usr/lib/perl5/5.10.0/i386-linux-thread-multi/DynaLoader.pm line 226.
Cleaned up stalled lock on /automount/wwkdev/elias/wdp.

Reverting again starts from the beginning. The user is able to reproduce until
his checkout is completely reverted.


Version-Release number of selected component (if applicable):
perl-SVK-2.0.2-3.fc9.noarch

How reproducible:
Error messages and failing reverting occurs every usage.

Steps to Reproduce (error message flood):
1. use svk

Steps to Reproduce (reverting):
1. checkout
2. merge branch with changes into checkout or alter multiple files
3. revert changes recursively
  
Actual results:
Massive flood of error messages as mentioned above.
Reverting multiple files interrupts.

Expected results:
No error messages.
Reverting not interrupting.

I noticed SVK is the same Version as in Fedora 8 - only perl version has
changed. So I assume it's an issue with perl-SVK in combination with perl 5.10.
I submitted this issue related to perl-SVK since it seems to only affect
perl-SVK so far (at least for my daily usage).

Comment 1 Ian Burrell 2008-07-15 21:19:34 UTC
The "Name used only once" message is a warning.  It seems to come from loading
SVN::Core (from subversion-perl package).

The "Attempt to free unreferenced scalar" and the locking are more serious errors.

I would suggest reporting the error upstream at
http://rt.cpan.org/Public/Dist/Display.html?Name=SVK.


Comment 2 Frank Wittig 2008-07-16 07:34:34 UTC
Reported upstream: http://rt.cpan.org/Public/Bug/Display.html?id=37715

Comment 3 Arkadiusz Miskiewicz 2008-08-10 08:34:57 UTC
"Attempt to free unreferenced scalar" is likely to be fixed by:
http://public.activestate.com/cgi-bin/perlbrowse/p/34025
as solution for bug http://rt.perl.org/rt3/Public/Bug/Display.html?id=54934

The other probably hapens with just subversion when doing make check-swig-pl (don't have fedora to test but it happens on other distro):
../../../../../subversion/bindings/swig/perl/native/t/6ra..............Name "swig_runtime_data::type_pointer3" used only once: possible typo at /usr/lib64/perl5/5.10.0/x86_64-xyz-linux-thread-multi/DynaLoader.pm line 226.

Comment 4 Stepan Kasal 2008-11-28 18:44:09 UTC
The other problem:

Name "swig_runtime_data::type_pointer3" used only once: possible typo at
/usr/lib/perl5/5.10.0/i386-linux-thread-multi/DynaLoader.pm line 226.

is files as bug #473407.

Comment 5 Derek Atkins 2009-01-14 15:16:17 UTC
Note that this is still a problem in Fedora 10.

Comment 6 Derek Atkins 2009-01-16 22:11:45 UTC
If the patch from comment #3 fixes this problem any chance we could see this in F10?  And maybe an SVK rebuild for F10 too?

Comment 7 Ian Burrell 2009-01-16 22:29:59 UTC
Unfortunately, the patch in comment #3 that fixes perl bug #54934 is to PerlIO::via which is in the perl package.  It will have to be applied there.  It sounds like newer version of PerlIO::via::dynamic may have a workaround for the bug in 5.10.0.

I will build the newest version of SVK.

Comment 8 Ian Burrell 2009-01-17 22:18:41 UTC
I added a bug (#480502) to the perl package to get the fix for PerlIO::via applied on the main perl package.

Comment 9 Fedora Update System 2009-01-19 10:52:44 UTC
perl-5.10.0-53.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/perl-5.10.0-53.fc10

Comment 10 Derek Atkins 2009-01-19 22:21:33 UTC
Yep, this definitely fixes all the problems I was seeing, except the "swig_runtime_data" warning.  But that's bug #473407.

I'll go mark some karma.

Comment 11 Fedora Update System 2009-01-21 21:39:11 UTC
perl-5.10.0-53.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.