Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455406 - Memory leak in Ruby interpreter
Summary: Memory leak in Ruby interpreter
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ruby
Version: 8
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL: http://redmine.ruby-lang.org/issues/s...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-15 12:50 UTC by Markus Schade
Modified: 2008-10-10 10:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-10 10:01:42 UTC


Attachments (Terms of Use)

Description Markus Schade 2008-07-15 12:50:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061712 Fedora/3.0-1.fc9 Firefox/3.0

Description of problem:
The ruby interpreter exhibits a memory leak in patchlevel 230 through 238.
Downgrading to ruby 1.8.6p110 or p114 (as shipped in f8 and f9) fixes this behaviour.
A fix is provided by upstream

Version-Release number of selected component (if applicable):
ruby-1.8.6.230-4.fc8

How reproducible:
Always


Steps to Reproduce:
http://pastie.org/227949


Actual Results:


Expected Results:


Additional info:

Comment 1 Akira TAGOH 2008-09-01 06:20:54 UTC
Can you test with ruby-1.8.6.287-1.fc10 again?

Comment 2 Paul Clifford 2008-09-01 14:34:18 UTC
I'm seeing the same thing in Fedora 9 with ruby-1.8.6.230-4, where one of our programs leaks 500+MB per day.  The upstream bug report has another link to demonstrate the problem: http://pastie.org/228006.  Running this with the F9 packages shows a jump in memory usage from about 3.5MB to 70MB by the end.

I built ruby-1.8.6.287-1.fc10.src.rpm for F9 and re-ran the test, and this time the memory usage only went up to 4.5MB.  That seems in line with the results I get from the ruby-1.8.5-5.el5_2.3 package in RHEL 5, so it appears to fix the problem.

Comment 3 Markus Schade 2008-10-10 10:01:42 UTC
It seems to be fixed by the current ruby-1.8.6.287-2.fc9.i386.


Note You need to log in before you can comment on or make changes to this bug.