Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455392 - Provide i386 version of fakeroot for x86_64
Summary: Provide i386 version of fakeroot for x86_64
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fakeroot
Version: 9
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Axel Thimm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-15 10:57 UTC by Lauri Leukkunen
Modified: 2009-04-27 21:22 UTC (History)
0 users

Fixed In Version: 1.12.2-21.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-04-14 06:15:53 UTC


Attachments (Terms of Use)

Description Lauri Leukkunen 2008-07-15 10:57:14 UTC
Description of problem:

When using i386 tools, 64bit fakeroot library can't be used. It would be nice to
have a 32bit fakeroot available.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Axel Thimm 2008-07-15 11:46:12 UTC
Can you please explain what doesn't work with i386? I'm using it quite often
that way, but maybe we use it differently.

Comment 2 Lauri Leukkunen 2008-07-15 13:28:50 UTC
I'm trying to run gcc cross compiler from codesourcery.com (2008q1) on a fedora
9 x86_64 box, the toolchain is built for i386:

[lleukkun@multileka ~]$ uname -a
Linux multileka.research.nokia.com 2.6.25.9-76.fc9.x86_64 #1 SMP Fri Jun 27
15:58:30 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux

[lleukkun@multileka ~]$ fakeroot arm-none-linux-gnueabi-gcc
ERROR: ld.so: object 'libfakeroot.so' from LD_PRELOAD cannot be preloaded: ignored.
arm-none-linux-gnueabi-gcc: no input files

[lleukkun@multileka bin]$ file arm-none-linux-gnueabi-gcc
arm-none-linux-gnueabi-gcc: ELF 32-bit LSB executable, Intel 80386, version 1
(SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.2.5, stripped


There is only one libfakeroot.so on the whole system:
[root@multileka ~]# find / -name "libfakeroot.so"
/usr/lib64/libfakeroot/libfakeroot.so

which is a symlink to:
[root@multileka ~]# file /usr/lib64/libfakeroot/libfakeroot-0.so 
/usr/lib64/libfakeroot/libfakeroot-0.so: ELF 64-bit LSB shared object, x86-64,
version 1 (SYSV), stripped



Comment 3 Axel Thimm 2008-07-15 17:19:40 UTC
Can you try running arm-none-linux-gnueabi-gcc in fakeroot i386 bash

$ uname -m -p -i
x86_64 x86_64 x86_64
$ fakeroot i386 bash
# uname -m -p -i
i686 athlon i386


Comment 4 Lauri Leukkunen 2008-07-17 07:07:27 UTC
Sure I can, but it does no good as there's no way the x86_64 library can be
loaded by the ld.so for a i386 binary. Incompatible. You need to provide a
libfakeroot.so built using -m32 switch. Just put both into LD_PRELOAD path, the
ld.so will pick the right one automatically.

Below is the output anyway:

-- clip --
[lleukkun@multileka ~]$ uname -m -p -i
x86_64 x86_64 x86_64
[lleukkun@multileka ~]$ fakeroot i386 bash
[root@multileka ~]# uname -m -p -i
i686 i686 i386
[root@multileka ~]# arm-none-linux-gnueabi-gcc
ERROR: ld.so: object 'libfakeroot.so' from LD_PRELOAD cannot be preloaded: ignored.
arm-none-linux-gnueabi-gcc: no input files
-- clip --

Comment 5 Axel Thimm 2008-07-17 13:16:51 UTC
OK, I'll ask to have fakeroot multiarch. In the meantime just coinstall the
fakeroot package from the i386 repo. If you find any issues please update this
ticket, thanks!

Comment 6 Axel Thimm 2009-04-14 06:15:53 UTC

*** This bug has been marked as a duplicate of bug 490953 ***

Comment 7 Fedora Update System 2009-04-14 06:59:58 UTC
fakeroot-1.12.2-21.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/fakeroot-1.12.2-21.fc9

Comment 8 Fedora Update System 2009-04-14 07:00:08 UTC
fakeroot-1.12.2-21.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/fakeroot-1.12.2-21.fc10

Comment 9 Fedora Update System 2009-04-27 21:21:46 UTC
fakeroot-1.12.2-21.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2009-04-27 21:22:41 UTC
fakeroot-1.12.2-21.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.