Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455386 - Xvfb: symbol lookup error: /usr/lib/dri/swrast_dri.so: undefined symbol: _glapi_add_dispatch
Summary: Xvfb: symbol lookup error: /usr/lib/dri/swrast_dri.so: undefined symbol: _gla...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: 9
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-15 10:16 UTC by Lars Heer
Modified: 2008-09-16 23:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-29 12:12:27 UTC


Attachments (Terms of Use)

Description Lars Heer 2008-07-15 10:16:44 UTC
Description of problem:
Xvfb: symbol lookup error: /usr/lib/dri/swrast_dri.so: undefined symbol:
_glapi_add_dispatch

Version-Release number of selected component (if applicable):
mesa-dri-drivers-7.1-0.37.fc9.i386

How reproducible:
Xvfb :1

Additional info:
http://groups.google.com/group/linux.debian.changes.devel/browse_thread/thread/2f46c8c02e2dceb5
* Build with --enable-glx-tls, we build mesa with TLS support (otherwise
     swrast_dri.so might fail to load due to unresolved symbols).

Comment 1 Thomas Vander Stichele 2008-07-18 13:28:27 UTC
-EMETOO.

I found http://lists4.opensuse.org/opensuse-commit/2008-07/msg00160.html that
seems related.

Why is this low priority if this is a crasher bug ? Xvfb does not work at all.

Comment 2 Adam Jackson 2008-07-21 14:37:26 UTC
Fedora doesn't build with GLX TLS support, it's not selinux-friendly.

This is working for me in 1.4.99.905-1.blah in updates-testing...

Comment 3 Vincent Pomerol 2008-07-21 20:02:55 UTC
(In reply to comment #2)
> Fedora doesn't build with GLX TLS support, it's not selinux-friendly.
> 
> This is working for me in 1.4.99.905-1.blah in updates-testing...

Can you be more specific about what "blah" is?  The version number
(1.4.99.905-1) matches my presently installed package, and it does not work.

It is not clear from the above comments whether the solution lies in the mesa
driver or the Xvfb server. How can I get the required package(s) in order to get
this to work.

Here is what I have now:

xorg-x11-server-Xvfb-1.4.99.905-1.20080701.fc9.x86_64
mesa-dri-drivers-7.1-0.37.fc9.x86_64

Let me also second the last point in Comment #1 about the low priority
assignment on a broken utility.  For some people it can be and is a critical
component.

Comment 4 Anthony Underwood 2008-07-22 12:17:10 UTC
I too have 

xorg-x11-server-Xorg-1.4.99.905-1.20080701.fc9.x86_64
mesa-dri-drivers-7.1-0.37.fc9.x86_64

and when I try to run xvfb get the error
Xvfb: symbol lookup error: /usr/lib/dri/swrast_dri.so: undefined symbol: _glapi_add_dispatch

This is a high priority bug for me since xvfb does not work with no obvious fix. Please bump this to 
high priority

Thanks



Comment 5 Lars Heer 2008-07-23 04:45:36 UTC
It is not working in stable tree - so IMHO priority has to be set higher...

I resolved the problem by installing the initial xorg-x11-server-Xvfb FC9
package... 

Comment 6 Anthony Underwood 2008-07-23 08:54:59 UTC
Yep this worked for me also. Many thanks
(In reply to comment #5)
> It is not working in stable tree - so IMHO priority has to be set higher...
> 
> I resolved the problem by installing the initial xorg-x11-server-Xvfb FC9
> package... 




Comment 7 Vincent Pomerol 2008-07-24 13:21:49 UTC
(In reply to comment #5)
> It is not working in stable tree - so IMHO priority has to be set higher...
> 
> I resolved the problem by installing the initial xorg-x11-server-Xvfb FC9
> package... 

My apologies if I am missing something obvious, but where can I get the
'initial' xorg-x11-server-Xvfb package?  The only fc9.x86_64 package that is
available from the mirrors is the broken version
xorg-x11-server-Xorg-1.4.99.905-1.20080701.fc9.x86_64 which is located in
updates.  Neither the original repository nor updates-testing (as mentioned in
comment #2) have a package called xorg-x11-server-Xvfb.

Comment 8 Anthony Underwood 2008-07-24 14:43:49 UTC
It can be downloaded from here
http://download.fedora.redhat.com/pub/fedora/linux/releases/9/Everything/i386/os/Packages/xorg-x11-server-Xvfb-1.4.99.901-29.20080415.fc9.i386.rpm
or here fore 64-bit version
http://download.fedora.redhat.com/pub/fedora/linux/releases/9/Everything/x86_64/os/Packages/xorg-x11-server-Xvfb-1.4.99.901-29.20080415.fc9.x86_64.rpm

This are the official release packages for F9
(In reply to comment #7)
> (In reply to comment #5)
> > It is not working in stable tree - so IMHO priority has to be set higher...
> > 
> > I resolved the problem by installing the initial xorg-x11-server-Xvfb FC9
> > package... 
> 
> My apologies if I am missing something obvious, but where can I get the
> 'initial' xorg-x11-server-Xvfb package?  The only fc9.x86_64 package that is
> available from the mirrors is the broken version
> xorg-x11-server-Xorg-1.4.99.905-1.20080701.fc9.x86_64 which is located in
> updates.  Neither the original repository nor updates-testing (as mentioned in
> comment #2) have a package called xorg-x11-server-Xvfb.




Comment 9 Fedora Update System 2008-07-24 16:00:39 UTC
xorg-x11-server-1.4.99.906-1.fc9 has been submitted as an update for Fedora 9

Comment 10 Fedora Update System 2008-09-12 14:48:08 UTC
xorg-x11-server-1.5.0-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xorg-x11-server-1.5.0-1.fc9

Comment 11 Fedora Update System 2008-09-16 23:26:45 UTC
xorg-x11-server-1.5.0-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.