Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455371 - [rpmlint] Mistakenly treat characters that has "A0" in it UTF8 code as non-break-space (nbsp)
Summary: [rpmlint] Mistakenly treat characters that has "A0" in it UTF8 code as non-br...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpmlint
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 466671 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-15 06:52 UTC by Ding-Yi Chen
Modified: 2008-11-22 16:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-31 10:25:22 UTC


Attachments (Terms of Use)

Description Ding-Yi Chen 2008-07-15 06:52:18 UTC
From Bugzilla Helper:
User-Agent: Opera/9.51 (X11; Linux i686; U; en)

Description of problem:
rpmlint treats non-break-space (nbsp, ASCII A0) as warning.
It seems that rpmlint check the nbsp by search the char "A0" in char arrays.
However it falsely considers characters such as 码 (U+7801) as nbsp, because 
its UTF-8 code is E7 A0 81.

Since 码 (meaning: number, code) is frequently used in Simplfied Chinese 
summary, so it is good to fix it.

Version-Release number of selected component (if applicable):
rpmlint-0.83

How reproducible:
Always


Steps to Reproduce:
1. Put 码 (U+7801) in Summary or Description in any spec files
2. rpmlint <the spec>


Actual Results:
rpmlint returns W: non-break-space

Expected Results:
rpmlint does not show such warning

Additional info:

Comment 1 Ville Skyttä 2008-07-18 17:15:01 UTC
Could you upload a specfile that can be used to test this with somewhere or
attach it to this bug?  I'm not sure if I can enter the problematic characters
properly if I try to write one myself.

Comment 2 Ville Skyttä 2008-07-30 16:44:30 UTC
I think I managed to come up with a reproducer; this should be fixed upstream
and will be in the next post-0.84 release:
http://rpmlint.zarb.org/cgi-bin/trac.cgi/changeset/1446

Comment 3 Ding-Yi Chen 2008-08-04 03:03:03 UTC
(In reply to comment #1)
> Could you upload a specfile that can be used to test this with somewhere or
> attach it to this bug?  I'm not sure if I can enter the problematic characters
> properly if I try to write one myself.

In case you still need an sample spec, try man-pages-ko.spec

Regards,
Ding-Yi Chen

Comment 4 Ville Skyttä 2008-08-04 15:47:24 UTC
Thanks, upstream svn head seems to do the job just fine with man-pages-ko.spec.

Comment 5 Ville Skyttä 2008-10-12 17:36:51 UTC
*** Bug 466671 has been marked as a duplicate of this bug. ***

Comment 6 Ville Skyttä 2008-10-17 06:09:19 UTC
There is no rpmlint release that contains the fix in any Fedora version yet, reopening.

Comment 7 Fedora Update System 2008-10-23 20:54:15 UTC
rpmlint-0.85-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/rpmlint-0.85-1.fc9

Comment 8 Fedora Update System 2008-10-24 23:49:25 UTC
rpmlint-0.85-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rpmlint'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9125

Comment 9 Fedora Update System 2008-10-31 10:24:59 UTC
rpmlint-0.85-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2008-11-04 17:37:02 UTC
rpmlint-0.85-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/rpmlint-0.85-2.fc10

Comment 11 Fedora Update System 2008-11-22 16:55:28 UTC
rpmlint-0.85-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.