Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455369 - [as_IN][ta_IN] locale showing GTK warning during run applications from terminal
Summary: [as_IN][ta_IN] locale showing GTK warning during run applications from terminal
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gtk2
Version: 5.2
Hardware: i386
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Matthias Clasen
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
: 868436 868441 868448 (view as bug list)
Depends On:
Blocks: 771748
TreeView+ depends on / blocked
 
Reported: 2008-07-15 06:34 UTC by Yolkfull Chow
Modified: 2013-04-30 22:56 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-20 07:01:12 UTC


Attachments (Terms of Use)
Updated assamese translations for gtk2 (deleted)
2008-07-17 07:07 UTC, Amitakhya Phukan
no flags Details
Updated ta.po file (deleted)
2008-07-17 09:44 UTC, Felix
no flags Details
Assamese (as.po), Tamil (ta.po) translation fixed patch (deleted)
2010-04-14 09:34 UTC, Ankit Patel
no flags Details | Diff

Description Yolkfull Chow 2008-07-15 06:34:52 UTC
Description of problem:
When launch firefox in terminal with locale as_IN.utf-8, following GTK warning
will be presented:

----------
(firefox:14890): Gtk-WARNING **: Whoever translated default:LTR did so wrongly.
---------

Launch firefox with other locales will not get this warning message.

Version-Release number of selected component (if applicable):
firefox-3.0.1-1.el5

How reproducible:
Everytime

Steps to Reproduce:
1. export LANG to as_IN
2. launch firefox in terminal
3.
  
Actual results:


Expected results:


Additional info:
This also happen on x86_64 arch.

Comment 1 Lawrence Lim 2008-07-16 07:05:59 UTC
is as_IN language support installed?

Comment 2 lihuang 2008-07-16 09:50:57 UTC
In tamil (ta_IN ) locale . GTK warning also be given . while the others south
Asia locale have no problem.

This msg also be given when launch other application,for example gedit.evince

( I am not sure about how to comfirm language support is installed or not
# rpm -qa | grep tamil
m17n-db-tamil-1.3.3-48.el5.noarch
fonts-tamil-2.1.7-2.el5.noarch
is it mean tamil support installed? )



Comment 3 A S Alam 2008-07-16 09:56:56 UTC
it is GTK issue in mentioned locale, issue should be file again gtk2 instead for
f irefox, it can be tested for gedit also and please try to query for gtk with
above error.

Comment 4 A S Alam 2008-07-16 09:59:34 UTC
Ref bug: Bug 431988: [as_IN] Error in Translated file
(not for RHEL, but have a reference)

Comment 5 A S Alam 2008-07-16 10:05:35 UTC
Adding ta_IN languages and l10n list for look up issue.

Comment 6 Ankit Patel 2008-07-16 11:04:36 UTC
Can I have the respective as.po and ta.po files?

When I grabbed the source package from
http://porkchop.redhat.com/released/RHEL-5-Client/U2/source/SRPMS/gtk2-2.10.4-20.el5.src.rpm
, couldn't find as.po file. and ta.po file was also very old.

So, I doubt, the package structure and/or the files are wrong/old, I don't know
what it is now.

Requesting the package maintainers to provide the location of the latest .po
files for Assamese (as.po) and Tamil (ta.po)

Comment 8 Yolkfull Chow 2008-07-17 05:30:06 UTC
#rpm -q gtk2
gtk2-2.10.4-20.el5

BTW,this is the latest build in our brew.

Comment 9 Amitakhya Phukan 2008-07-17 06:43:38 UTC
i couldn't find gtk2 in the GNOME repository .. i found gtk+ .. i have updated
the translations for assamese (as-IN) for gtk+ head, and branches 2-10 and 2-12.
please get back to me for any further info.

Comment 10 Amitakhya Phukan 2008-07-17 07:07:06 UTC
Created attachment 312010 [details]
Updated assamese translations for gtk2

I have corrected the translations that were submitted as a tarball in bug
218598. also, you can use the translations that I have submitted upstream in
the GNOME repositories.

Comment 11 Felix 2008-07-17 09:44:12 UTC
Created attachment 312025 [details]
Updated ta.po file

I correct the default:LTR string in the ta.po file and attached

Comment 12 lihuang 2008-07-28 07:18:55 UTC
reproduce on RHEL5.2 Client x86_64 
# uname -a
Linux x86-64-5c-1-m1.lab.bos.redhat.com 2.6.18-92.el5xen #1 SMP Tue Apr 29
13:31:30 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux


Comment 13 RHEL Product and Program Management 2009-03-26 17:06:11 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 15 Jens Petersen 2010-04-14 05:01:03 UTC
Is this fixed in Fedora?

Comment 16 Ankit Patel 2010-04-14 09:34:26 UTC
Created attachment 406444 [details]
Assamese (as.po), Tamil (ta.po) translation fixed patch

Hi,

Applying this patch against "po" directory of gtk2 package would solve the issue.

FYI: we (localization team) are following similar approach of providing updated translations for RHEL6 as well, which is documented here: https://engineering.redhat.com/trac/LocalizationServices/wiki/L10nRHEL6TranslationBugs

Thanks!
Ankit

Comment 18 Jens Petersen 2010-04-20 07:11:14 UTC
Thank - probably unlikely to get fixed in RHEL5 IMHO.

Most important thing is that it is fixed in upstream, Fedora and RHEL 6,
which looks to be the case based on comment 9.

Comment 19 A S Alam 2012-10-22 06:43:39 UTC
*** Bug 868436 has been marked as a duplicate of this bug. ***

Comment 20 A S Alam 2012-10-22 06:44:19 UTC
*** Bug 868448 has been marked as a duplicate of this bug. ***

Comment 21 A S Alam 2012-10-22 06:46:46 UTC
*** Bug 868441 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.