Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455368 - Some lang pack plugin doesn't work
Summary: Some lang pack plugin doesn't work
Keywords:
Status: CLOSED DUPLICATE of bug 455727
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox
Version: 5.2
Hardware: i386
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Gecko Maintainer
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-15 06:18 UTC by Yolkfull Chow
Modified: 2008-07-18 08:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-18 08:02:52 UTC


Attachments (Terms of Use)

Description Yolkfull Chow 2008-07-15 06:18:48 UTC
Description of problem:
Fonts in korean,Japanese,Chinese simplified & Chinese Traditional cannot be
displayed correctly while others work fine. I tried re-enable the four
language's plugins and restart firefox, still doesn't work.

Version-Release number of selected component (if applicable):
firefox-3.0.1-1.el5

How reproducible:
Everytime

Steps to Reproduce:
1.
2.
3.
  
Actual results:
The four languages' fonts could not be displayed correctly.

Expected results:
All fonts should be displayed successfully if language plugins have been installed.

Additional info:

Comment 1 Matěj Cepl 2008-07-15 14:54:28 UTC
Please, be a little bit more specific. Could we get exact steps how me (how
doesn't have CJK locale and doesn't know what's important there) could reproduce
the problem? Could you point out some specific page which doesn't display
correctly (and show me how it should look like), please?

Thank you very much

Comment 2 Christopher Aillon 2008-07-15 15:44:21 UTC
related to bug 454387 ?

Comment 3 Lawrence Lim 2008-07-16 07:04:55 UTC
llim->ndai, could you please follow up on this?

Thanks.

Comment 4 Yolkfull Chow 2008-07-18 07:57:35 UTC
I am sorry for that I made a mistake about the usage of language pack extension
of firefox. According to the mozilla-support
(http://support.mozilla.com/zh-CN/kb/Changing+the+language+pack), the language
pack is used only for changing the language of the APP,such as menus etc, while
will not change the content of web. Sorry again!

But I found another problem during I was investigating this. According to the
page of mozilla-support,does change "general.useragent.locale" in about:config
will immediately change the language of the APP(menus say) after restart
firefox? If yes, we need open another bug against this.If no, could anybody
please tell me why? 
Because I did some test on this and found that only when I change the locale can
firefox change to the corresponding language of the APP.
Thanks in advance.

Comment 5 Martin Stransky 2008-07-18 08:02:52 UTC
It's Bug 455727

*** This bug has been marked as a duplicate of 455727 ***


Note You need to log in before you can comment on or make changes to this bug.