Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455344 - perl-XML-Stream should require perl(IO::Socket::SSL)
Summary: perl-XML-Stream should require perl(IO::Socket::SSL)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-XML-Stream
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Chris Weyl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 455319
TreeView+ depends on / blocked
 
Reported: 2008-07-14 21:57 UTC by Robert Scheck
Modified: 2008-07-15 04:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-15 04:12:25 UTC


Attachments (Terms of Use)

Description Robert Scheck 2008-07-14 21:57:55 UTC
Description of problem:
Without having perl(IO::Socket::SSL) installed, it is not possible to use
perl-XML-Stream with a TLS/SSL connection. So please add this as requirement. 
See the following reproducer for example.

$ rpm -e perl-IO-Socket-SSL --nodeps
$

$ sendxmpp --magic-things ;-)
[...]
"You requested that XML::Stream turn the socket into an SSL socket, but you 
don't have the correct version of IO::Socket::SSL v0.81. at /usr/lib/perl5/
vendor_perl/5.8.8/XML/Stream/Node.pm line 547"
[...]
$

Once re-install perl-IO-Socket-SSL again, the message disappears and everything 
TLS/SSL related works for me.

Version-Release number of selected component (if applicable):
perl-XML-Stream-1.22-7

How reproducible:
Everytime, e.g. sendxmpp with TLS/SSL jabber server.

Actual results:
perl-XML-Stream does not require perl(IO::Socket::SSL).

Expected results:
perl-XML-Stream should require perl(IO::Socket::SSL).

Comment 1 Chris Weyl 2008-07-15 04:12:25 UTC
Fixed.  Added Net::DNS, as well.

Thanks for the report! :)


Note You need to log in before you can comment on or make changes to this bug.