Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455333 - Error on installation of kernel-devel 2.6.26-136.fc10
Summary: Error on installation of kernel-devel 2.6.26-136.fc10
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 455433 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-14 20:38 UTC by Quentin Armitage
Modified: 2008-07-15 17:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-15 17:49:09 UTC


Attachments (Terms of Use)
/var/tmp/rpm-tmp.59649 file created by yum install kernel-devel (deleted)
2008-07-14 20:38 UTC, Quentin Armitage
no flags Details

Description Quentin Armitage 2008-07-14 20:38:23 UTC
Description of problem:
I get the following error on installation of kernel-devel 2.6.26-
136.f10
/var/tmp/rpm-tmp.59649: line 12:  : command not found
error: %post(kernel-devel-2.6.26-136.fc10.i686) scriptlet failed, exit status 
127

Version-Release number of selected component (if applicable):
kernel-2.6.26-136.fc10

How reproducible:
Always

Steps to Reproduce:
1.yum install kernel-devel
2.
3.
  
Actual results:
Error message given above

Expected results:
No error message

Additional info:
Up to and including kernel-2.6.26-0.131.fc9.git9.fc10 I didn't get the error 
messages.
Version of rpm installed: rpm-4.4.2.3-2.fc9.i386. (I haven't yet updated rpm to
4.5.90-0.git8426.6 due to dependency failures. I will file a separate bug for that.

I attach a new /var/tmp/rpm-tmp.59649. It is not easy to catch since it only
exists for a few milli-seconds.

There appears to be a stray \x19 (^Y) character at end of the file (line 12)

See bug 455307 for original details.

Comment 1 Quentin Armitage 2008-07-14 20:38:23 UTC
Created attachment 311774 [details]
/var/tmp/rpm-tmp.59649 file created by yum install kernel-devel

Comment 2 Quentin Armitage 2008-07-14 22:02:25 UTC
Problem still occurs with rpm version rpm-4.5.90-0.git8426.6.i386


Comment 3 sangu 2008-07-14 23:06:23 UTC
This issue happens in rpm-4.4.2.3-2.fc9.i386, too.

Comment 4 Panu Matilainen 2008-07-15 07:01:11 UTC
Ok, there IS a stray character at the last line of the script in that package,
shell is going to barf on that no matter what rpm version you try with. It's a
build/macro expansion issue with the new rpm, off-by-one somewhere or similar.
Doesn't seem to be reliably reproducable (haven't been able to reproduce it yet)
so it might be hard to find, but I'll look into it.

Comment 5 Panu Matilainen 2008-07-15 17:41:56 UTC
*** Bug 455433 has been marked as a duplicate of this bug. ***

Comment 6 Panu Matilainen 2008-07-15 17:49:09 UTC
This should be fixed in rpm-4.5.90-0.git8426.8 which just finished building.
Again, note it's a build-, not run-time issue so you wont see any change until a
new kernel package is built with the fixed rpm.


Note You need to log in before you can comment on or make changes to this bug.