Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455311 - Desktop file is annoying
Summary: Desktop file is annoying
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Lillian Angel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-14 19:31 UTC by Bastien Nocera
Modified: 2008-10-30 17:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-30 17:33:14 UTC


Attachments (Terms of Use)

Description Bastien Nocera 2008-07-14 19:31:37 UTC
The /usr/share/applications/fedora-policytool.desktop desktop file is installed
in the useless "Other" menu, and is probably completely useless to anyone, but a
few people.

And what does "OpenJDK Policy Tool" mean?

Just make it hidden, it will be better for everyone.

Comment 1 Lillian Angel 2008-07-14 19:46:38 UTC
what is it?: http://linux.die.net/man/1/policytool

I am closing this bug.

Comment 2 Lubomir Rintel 2008-07-14 20:37:29 UTC
Actually that has a point -- it really should not be in Other menu at least.
There is a "System Tools" menu that may suit better.

Comment 3 Lillian Angel 2008-07-14 21:59:40 UTC
we can change where it shows up in the menu, but i dont think making it hidden is a solution.

i will reopen this, and it should be moved to somewhere more appropriate in the next release.

Comment 4 Bastien Nocera 2008-07-14 22:07:27 UTC
Next release? You clearly install the desktop file using desktop-file-install,
so it's a one-liner in the spec file fixing the desktop file to not be installed
in some random place.

I don't really care what it's supposed to do, but the label needs to be changed
to something better. "Java Policy Editor" or something.

Even better would be to split it out in a sub-package, so I don't need to see it.

Comment 5 Lillian Angel 2008-07-15 12:53:46 UTC
Yes, it will be in the next release/build of openjdk. It doesn't matter that it is a one-liner, it would require  
a rebuild and this problem is not urgent enough to warrant one.

Bastien- understand the issue is not extremely urgent, and it will get done.

Comment 6 Lillian Angel 2008-07-15 12:55:04 UTC
Also, the name will not be changed. Sun has named the tool "Policy Tool", and we cannot change that.

Comment 7 Ville Skyttä 2008-07-15 20:33:25 UTC
Looks like this annoyance is because the jconsole and policytool desktop files
have lost the "Development" category which was present when I submitted them in
bug 417501. 

Both have also lost the TryExec key.  I suggest adding that back as well, see
initial comment in bug 417501 for the rationale.

Comment 8 Bastien Nocera 2008-07-20 22:26:32 UTC
(In reply to comment #6)
> Also, the name will not be changed. Sun has named the tool "Policy Tool", and
we cannot change that.

It could also be renamed "Java Policy Tool". I think the mention of the JDK in
the desktop filename is contrary to the guidelines, and common sense.

Comment 9 Lillian Angel 2008-07-23 17:13:31 UTC
We cannot call it "Java Policy Tool" due to trademark issues. It will remain
named "OpenJDK Policy Tool". I will add the Development category back in. Thanks
for pointing that out.


Note You need to log in before you can comment on or make changes to this bug.