Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455307 - "/sbin/ldconfig: /lib/ld-linux.so.2 is not a symbolic link" when installing kernel
Summary: "/sbin/ldconfig: /lib/ld-linux.so.2 is not a symbolic link" when installing k...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F10Blocker, F10FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2008-07-14 19:12 UTC by Quentin Armitage
Modified: 2008-10-29 17:36 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-29 17:36:08 UTC


Attachments (Terms of Use)
/var/tmp/rpm-tmp.59649 file created by yum install kernel-devel (deleted)
2008-07-14 20:06 UTC, Quentin Armitage
no flags Details

Description Quentin Armitage 2008-07-14 19:12:20 UTC
Description of problem:
I get the following errors on installation of kernel and kernel-devel 2.6.26-
136.f10
For kernel:
/sbin/ldconfig: /lib/ld-linux.so.2 is not a symbolic link

For kernel-devel:
/var/tmp/rpm-tmp.92170: line 12:  : command not found
error: %post(kernel-devel-2.6.26-136.fc10.i686) scriptlet failed, exit status 
127

Version-Release number of selected component (if applicable):
kernel-2.6.26-136.fc10

How reproducible:
Always

Steps to Reproduce:
1.yum install kernel kernel-devel
2.
3.
  
Actual results:
Error messages given above

Expected results:
No error messages

Additional info:
Up to and including kernel-2.6.26-0.131.fc9.git9.fc10 I didn't get the error 
messages.

BTW, should fedora_cvs_origin have been set to 760 for the 2.6.26 released 
kernel?

Comment 1 Dave Jones 2008-07-14 19:29:10 UTC
two separate bugs here.

/sbin/ldconfig: /lib/ld-linux.so.2 is not a symbolic link

is a mkinitrd bug.  (reassigned).


The other..
For kernel-devel:
/var/tmp/rpm-tmp.92170: line 12:  : command not found
error: %post(kernel-devel-2.6.26-136.fc10.i686) scriptlet failed, exit status 

is a mystery.
Can you cat /var/tmp/rpm-tmp.92170 and find out what command its barfing on?

Comment 2 Quentin Armitage 2008-07-14 20:06:09 UTC
Created attachment 311766 [details]
/var/tmp/rpm-tmp.59649 file created by yum install kernel-devel

Comment 3 Quentin Armitage 2008-07-14 20:07:03 UTC
I attach a new /var/tmp/rpm-tmp.nnnnn from a re-install. It is not easy to catch
since it only exists for a few milli-seconds.

There appears to be a stray \x19 (^Y) character at end of the file (line 12)

Comment 4 Dave Jones 2008-07-14 20:19:07 UTC
That looks like an rpm bug.  I recommend leaving this one for Peter to take care
of mkinitrd, and file a seperate one for the rpm bug.

Comment 5 Quentin Armitage 2008-07-14 20:39:07 UTC
rpm bug filed as 455333

Comment 6 Panu Matilainen 2008-07-15 17:56:04 UTC
Just FYI, the junk at end of script was a bug in rpm macro argument handling (a
build, not runtime issue) which should be fixed now in rpm-4.5.90-0.git8426.8
which just finished building.

The kernel spec is pretty heavy on macros making it a likely candidate for
catching regressions in that area...

Comment 7 Christopher D. Stover 2008-10-27 02:33:23 UTC
Has this still been an issues Quentin or can we close this as fixed in rawhide?

Comment 8 Tom "spot" Callaway 2008-10-29 17:36:08 UTC
Closing this as fixed, since I can no longer reproduce this. If it is not fixed in the Preview release, please reopen.


Note You need to log in before you can comment on or make changes to this bug.