Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455289 - Notification daemon crashes after changing theme
Summary: Notification daemon crashes after changing theme
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: notification-daemon
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-14 17:42 UTC by Martin Sourada
Modified: 2013-03-06 03:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-14 21:57:16 UTC


Attachments (Terms of Use)

Description Martin Sourada 2008-07-14 17:42:28 UTC
Description of problem:


Version-Release number of selected component (if applicable):
notification-daemon-0.3.7.90-0.svn3009.fc10
notification-daemon-0.3.7-9.fc9 as well

How reproducible:
always

Steps to Reproduce:
1. install notification-daemon-engine-nodoka
2. switch /apps/notification-daemon/theme to nodoka (or back to standard if you
use nodoka already)
  
Actual results:
Applications emitting notification bubbles stop emiting them, application
restart is necessary to get it working again. notify-send also usually does not
emit the requested bubble on first or second try, but not always, I don't see
any pattern as to how many tries or how much time it takes for the bubbles to
start displaying again.

Expected results:
Theme changes and notification bubbles continue display.

Additional info:
I am now back at F9, but the problem was reproducible on yesterdays rawhide as
well. When I reboot to rawhide again, I recheck the exact versions (though from
a quick look into koji it shouldn't be necessary).

Comment 1 Matthias Clasen 2008-07-14 21:57:16 UTC
Should be fixed in 0.3.7.90-1.svn3009.fc10

Comment 2 Martin Sourada 2008-07-15 21:18:33 UTC
Yep, seems it works now :-)


Note You need to log in before you can comment on or make changes to this bug.