Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455274 - 2.6.9-67.0.20.ELsmp kernel panic
Summary: 2.6.9-67.0.20.ELsmp kernel panic
Keywords:
Status: CLOSED DUPLICATE of bug 453507
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.6
Hardware: i686
OS: Linux
low
urgent
Target Milestone: rc
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-14 16:20 UTC by ralf hartings
Modified: 2008-07-15 12:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-15 12:56:19 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description ralf hartings 2008-07-14 16:20:16 UTC
Description of problem:
kernel panic and total system lock-up

Version-Release number of selected component (if applicable):
2.6.9-67.0.20.ELsmp

How reproducible:
Occurred 3 times in 2 weeks. Reported at CentOS: 
http://www.centos.org/modules/newbb/viewtopic.php?post_id=53184&topic_id=15191&forum=27#forumpost53184
by 3 independent users (2 CentOS and 1 RHEL)
When downgrading to the previous -15 kernel, no crashes in 4 days (=so far).

Steps to Reproduce:
1.Install kernel -20 or upgrade from prevous -15 kernel.
2.According CentOS forum above related to clamd or Surgemail (mail software), or
hardware depentdent
3.
  
Actual results:
Jul  9 01:29:37 server kernel: ------------[ cut here ]------------
Jul  9 01:29:37 server kernel: kernel BUG at kernel/exit.c:881!
Jul  9 01:29:37 server kernel: invalid operand: 0000 [#1]
Jul  9 01:29:37 server kernel: SMP 
Jul  9 01:29:37 server kernel: Modules linked in: nfsd exportfs lockd nfs_acl
parport_pc lp parport autofs4 i2c_dev i2c_core sunrpc dm_mirror dm_mod button
battery ac md5 ipv6 joydev ohci_hcd ehci_hcd forcedeth k8_edac edac_mc
snd_ymfpci snd_ac97_codec snd_pcm_oss snd_mixer_oss snd_pcm snd_opl3_lib
snd_timer snd_hwdep snd_page_alloc snd_mpu401_uart snd_rawmidi snd_seq_device
snd soundcore 3c59x mii floppy ext3 jbd raid1 sata_nv ahci libata sd_mod scsi_mod
Jul  9 01:29:37 server kernel: CPU:    1
Jul  9 01:29:37 server kernel: EIP:    0060:[<c01249e8>]    Not tainted VLI
Jul  9 01:29:37 server kernel: EFLAGS: 00010046   (2.6.9-67.0.20.ELsmp) 
Jul  9 01:29:37 server kernel: EIP is at next_thread+0xc/0x3f
Jul  9 01:29:37 server kernel: eax: 00000000   ebx: f775d6b0   ecx: 0057cff4  
edx: f77a4170
Jul  9 01:29:37 server kernel: esi: 00002ef9   edi: 00024e02   ebp: b7b81b00  
esp: ef481f8c
Jul  9 01:29:37 server kernel: ds: 007b   es: 007b   ss: 0068
Jul  9 01:29:37 server kernel: Process surgemail (pid: 3967, threadinfo=ef481000
task=f775d6b0)
Jul  9 01:29:37 server kernel: Stack: c012f19a 00000246 00000000 b7b81b28
b7b81b20 ef481fa8 b7b81b20 00000000 
Jul  9 01:29:37 server kernel:        c01262f8 b7b81b00 00000064 00000028
ef481000 c02d8b77 b7b81b00 0057cff4 
Jul  9 01:29:37 server kernel:        0057cff4 00000064 00000028 b7b81b18
0000002b 0000007b 0000007b 0000002b 
Jul  9 01:29:37 server kernel: Call Trace:
Jul  9 01:29:37 server kernel:  [<c012f19a>] sys_times+0x56/0x1c5
Jul  9 01:29:37 server kernel:  [<c01262f8>] sys_gettimeofday+0x9a/0xac
Jul  9 01:29:37 server kernel:  [<c02d8b77>] syscall_call+0x7/0xb
Jul  9 01:29:37 server kernel: Code: 85 c0 89 d3 74 05 e8 f3 9e ff ff 53 e8 df
fb ff ff 0f b6 44 24 04 c1 e0 08 50 e8 d1 fb ff ff 89 c2 8b 80 f0 04 00 00 85 c0
75 08 <0f> 0b 71 03 c0 a5 2e c0 0f b6 80 04 05 00 00 84 c0 7e 14 a1 00 
Jul  9 01:29:37 server kernel:  <0>Fatal exception: panic in 5 seconds

Expected results:
No panic, normal operation

Additional info:

Comment 1 Tom Sightler 2008-07-14 17:35:39 UTC
I believe this is a duplicate of BZ 453507.  There is a patch available in that
Bugzilla that might help.  I've opened a support case with Redhat to get a test
kernel with the patch.




Comment 2 Prarit Bhargava 2008-07-15 12:56:19 UTC

*** This bug has been marked as a duplicate of 453507 ***


Note You need to log in before you can comment on or make changes to this bug.