Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455267 - quoting issue in rpm scriptlets causes error message
Summary: quoting issue in rpm scriptlets causes error message
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-14 15:32 UTC by Valdis Kletnieks
Modified: 2008-07-19 16:15 UTC (History)
1 user (show)

Fixed In Version: 3.0.0-0.0.25.1.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-19 16:15:24 UTC


Attachments (Terms of Use)

Description Valdis Kletnieks 2008-07-14 15:32:22 UTC
Description of problem:
Bad quoting in this scriptlet:
preinstall scriptlet (using /bin/sh):
if [ $1 -gt 1 ]; then
    # Upgrade => deregister old extension
    unopkg remove --shared `grep identifier
/usr/lib64/openoffice.org/extensions/presenter-screen.oxt/description.xml | cut
-d\\\" -f 2` || :
fi
causes yum to throw an error:

/usr/src/redhat/tmp/rpm-tmp.58165: command substitution: line 3: unexpected EOF
while looking for matching `"'
/usr/src/redhat/tmp/rpm-tmp.58165: command substitution: line 4: syntax error:
unexpected end of file
  Updating       : openoffice.org-presenter-screen                 [ 6/39] 

Looks like -d\\\" doesn't have quite enough \ in it.  Would -d'"' work better?
(similar issue in preuninstall scriptlet)

Version-Release number of selected component (if applicable):
openoffice.org-presenter-screen-3.0.0-0.0.24.1.fc10.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Caolan McNamara 2008-07-14 15:53:02 UTC
Hmm, thanks. Lets try that instead

Comment 2 Caolan McNamara 2008-07-19 16:15:24 UTC
Fixed in 3.0.0-0.0.25.1.fc10, though note that the m24 one on uninstalling will
probably still warn, but the m25 on installing and from there onwards will be ok


Note You need to log in before you can comment on or make changes to this bug.