Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455197 - iptables-restore fails
Summary: iptables-restore fails
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: iptables
Version: 9
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-13 22:19 UTC by Jerry Vonau
Modified: 2009-02-17 12:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-02-17 12:59:48 UTC


Attachments (Terms of Use)

Description Jerry Vonau 2008-07-13 22:19:08 UTC
Description of problem:
-A loc2fw -p 6 --dport 8080 -m conntrack --ctorigdst ! 10.3.0.10 -j ACCEPT
fails with:
iptables-restore v1.4.1.1: host/network `!' not found
Try `iptables-restore -h' or 'iptables-restore --help' for more 
information.

Version-Release number of selected component (if applicable):
libnetfilter_conntrack-0.0.89-0.1.svn7356.fc9.i386

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Paul P Komkoff Jr 2008-08-01 18:46:46 UTC
iptables has nothing to do with libnetfilter_conntrack.

Comment 2 Thomas Woerner 2009-02-17 12:59:48 UTC
Please have a look at the man page. The syntax of the ctorigdst option is:
  [!] --ctorigdst address[/mask]

Closing as NOT A BUG.


Note You need to log in before you can comment on or make changes to this bug.