Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455188 - Package apr-devel should not contains .la files
Summary: Package apr-devel should not contains .la files
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: apr
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-13 19:26 UTC by Jochen Schmitt
Modified: 2008-07-14 18:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-14 18:54:42 UTC


Attachments (Terms of Use)

Description Jochen Schmitt 2008-07-13 19:26:54 UTC
Package apr-devel contains the file

%{_libdir}/libapr-1.la

The packaging policies sayys thst packagess should not contains files with the
extension .a or .la if there not a good reason to do it.

Comment 1 Bojan Smojver 2008-07-13 21:21:55 UTC
apr-1-config script has an option --link-libtool, which returns this file. If we
remove it from apr-devel, we shall break source compatibility of packages that
depend on this option in order to build against apr. This is against project's
versioning rules.

See: http://apr.apache.org/versioning.html#source

Comment 2 Jochen Schmitt 2008-07-14 14:16:45 UTC
I think we should patch this script. In rawhide we can make changes which may 
break the compatiblity. Of corse we should not port this update on F-9 aor F-8.

Comment 3 Joe Orton 2008-07-14 18:54:42 UTC
No.  The packaging guidelines' "should not" is not a mandate for removal and
does not trump following upstream.  We have a good reason for keeping there,
I've been over this several times already, see the review bug.


Note You need to log in before you can comment on or make changes to this bug.