Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 455186 - zeroconf route on non-dhcp interface
Summary: zeroconf route on non-dhcp interface
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 9
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-07-13 18:17 UTC by Jerry Vonau
Modified: 2014-03-17 03:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-15 00:26:43 UTC


Attachments (Terms of Use)

Description Jerry Vonau 2008-07-13 18:17:20 UTC
Description of problem:
zeroconf route appears in routing table with no interfaces using dhcp 

Version-Release number of selected component (if applicable):
initscripts-8.76.2-1.i386


How reproducible:
Look at the any routing table, zeroconf route on the last interface to be enabled.

Steps to Reproduce:
1. /sbin/down eth0
2. /sbin/up eth0
3. look at the routing table
  
Actual results:
169.254.0.0/16 dev eth0  scope link 

Expected results:
no zeroconf route

Additional info:
diff to ifup-eth
 # Add Zeroconf route.
-if [ -z "${NOZEROCONF}" -a "${ISALIAS}" = "no" -a "${REALDEVICE}" != "lo" ]; then
+if [ -z "${NOZEROCONF}" -a "${DYNACONFIG}" = "true" -a "${ISALIAS}" = "no" -a
"${REALDEVICE}" != "lo" ]; then
     ip route replace 169.254.0.0/16 dev ${REALDEVICE} 
 fi

Comment 1 Jerry Vonau 2008-07-13 18:20:16 UTC
make that:

1. /sbin/ifdown eth0
2. /sbin/ifup eth0
 

Comment 2 Bill Nottingham 2008-07-14 15:37:50 UTC
There's no reason to not have the route for static IPs as well. Or am I
misunderstanding what you're asking?

Comment 3 Jerry Vonau 2008-07-14 18:07:29 UTC
Ok, lets expand a bit, a dhcp device would be un-configured until it's plugged
in and received a lease, while you can have a static ip address for a device
that, I would consider to be configured because of the network info, even if not
plugged in. If you have 2 or interfaces, one dhcp while the rest are static, the
last one to be enabled will get that route, not the newly "configured" dhcp
interface, done by a dhcp server. 

Is that not the point of zeroconf? adding a ipaddr/route to a device that is not
configured? Would this not be better added(created?) when dhcp couldn't
get/renew a lease? What ip address is used with this 169.254 route?


  

Comment 4 Bill Nottingham 2008-07-15 00:26:43 UTC
While it is the last interface configured, keying off of DYNCONFIG is the wrong
key - after all, you could have your static/dynamic devices ordered in any way.

Using the last device is the same algorithm used for gateway; considering that,
leaving the code as-is makes sense.


Note You need to log in before you can comment on or make changes to this bug.